By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

No sound or crappy sound on Kubuntu 13.10

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

Skype sound playback was always broken on ubuntu (tested on many configurations and OS versions). When starting playbeck (not matter that was a sample or started connection) few seconds on start always was crappy. 

On upcoming Kubuntu 13.10 there is bigger problem. There is no sound playback or its crappy all the time.
Im not sure its system problem because there was similar problem on older kubuntu version.

Other audio software works great, so i guess thats Skype fault.

Now on kubuntu 13.10 skype is not to use. 

Message 1 of 15 (11,927 Views)
14 Replies
Casual Adventurer
Message 2 of 15 (11,922 Views)
Novel Tourist

I just wanted to chime in to say that I think this is an issue with the newest skype (4.2.0.11-1) not working with anything that uses KDE.

 

My computer itself has sound and my microphone works with Audacity, so I know everything but skype is working. I have Linux Mint (Ubuntu) with KDE.

 

It happened very suddenly. I reinstalled Skype, then suddenly there was no sound. It went from working to not working within 30 seconds all due to an upgrade. I also am getting crash problems now and never had them before.

 

Someone else is also having this problem. http://community.skype.com/t5/Linux/4-2-0-11-1-for-linux-crashes-when-answering-calls/td-p/1655001

 

I'm going to try his solution and see if it works. You may want to try that, too!

 

Edit: I did the solution in the link. It downloads Pulse Audio. From there, you'll need to hit "Options -> Sound Devices -> open Pule Audio Control"

If you can't record, check under "recording" to make sure the right mic is selected. If You can't hear anything, check under "output devices" instead.

Casual Adventurer

After restart problem appears again. No sound or crappy sound quality.

Message 4 of 15 (11,856 Views)
Novel Adventurer

just to tailgate on this, I have Ubuntu 13.04 and skype 4.2.0.11 working A-ok, but a 13.10-beta1 with skype 4.2.0.11 with the new multiarch stuff seems to result in choppyunusable audio, both in and out.

Message 5 of 15 (11,734 Views)
Casual Adventurer

I found that this problem is related to pulse audio master update in 13.10.

Its possible to get skype working well. Just run it with special command:

Exec=/usr/bin/env PULSE_LATENCY_MSEC=30 /usr/bin/skype

 Of course its workarount and it should be solved by skype developers team.

Message 6 of 15 (11,566 Views)
Novel Adventurer

awesome, works a treat, thanks for the hint! :bigsmile:

Message 7 of 15 (11,540 Views)
Casual Tourist

Pulse never really worked on my laptop so I am using alsa, but I wanted to play with the "solution" here and decided to uninstall alsa and reinstall pulseaudio.

Removing alsa tells me it will also remove kubuntu-desktop and my linux- kernel generic 3.11.3 (yes I installed that last week.)

Installing pulse will remove linux- kernel generic 3.11.3, but I wanted to keep that.

On my main 13.04 skype works just fine. I have set up skype the same for both 13.04 and 13.10. Same version 4.2.0.11, same settings.

I will try and boot into another kernel and see what that does.

Edit: It doesn't matter which kernel I use. 3.11.3, 3.10.x, 3.09.x I get the same clackes up voice.

Is there a work around for alsa, I wonder?

Message 8 of 15 (11,246 Views)
Novel Adventurer

Hi,   I tried your fix, and skype loads from the terminal, but when Itry to sign in it says that  I am already signed in, when in fact I am not, so didnot get the chance to test the sound, any Ideas?

Message 9 of 15 (11,186 Views)
Highlighted
Novel Adventurer

VOW! You have saved my life!

Message 10 of 15 (10,997 Views)
Discussion Stats
  • 14 replies
  • 11928 views
  • 11 kudos
  • 10 in conversation