By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Having trouble signing in? Retirement of older versions of Skype for Linux

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Staff Moderator

From today, users with Skype for Linux version 4.2 and older will not be able to sign in to Skype. The error messages user will see during sign in may include “Can’t Connect to Skype” or ”Can’t login on Skype”. To continue using Skype, please update to the latest version. 


Learn more about these changes.

259 Replies
Casual Adventurer

on kubuntu 14.04 skype 4.3 just wont work because it just don't allow me to choose microphone or speakers. i have only one option, something like virtual device. it's useless. my regards to skype, and pass it forth to microsoft. p.s.  if you want linux users to pay for it, it would be honest to say so.

best regards, i'm going to delete my account.

Dusko

Message 2 of 260 (40,692 Views)
Casual Tourist

It is a grim day. I dont want to update from 4.2! Why? BEACUSE IT IS WORKING ... WORKING read this word now: WORKING ! The magic word is WORKING get it? WORKING!

I dont want different UI or anything newer version tries to sell me.

I want old version because:

1. No bs metrolike bs interface!

2. screen sharing actually works like it supposed to compared to anything above 4.2

3. It's fine like it is, dont fix stuff that isn't broken!!!

 

If it takes to give you basterds the $ to keep it going so be it but dont just force users!!!

 

 

Message 3 of 260 (40,674 Views)
Casual Tourist

I can't login now to skype 4.2

Message 4 of 260 (40,629 Views)
Casual Tourist

Hello, I am using kubuntu 14.04.1 (trusty) with kernel: 3.13.0-32 and I upgraded to skype: 4.3.0.37
because the old version wasn't letting me sign in. Now the new version signs me in and immediately crashes. Any ideas?

 

 

 

Message 5 of 260 (40,604 Views)
Novel Adventurer

Have been running Skype 4.1.0.20 on Fedora 16. Do not recall being warned / informed of available updates, just that Skype intended to not provide further support.

 

I have downloaded package skype-4.3.0.37-fedora.i586.rpm and am having problems.

 

The new package did not cleanly update from the old package. So uninstalled 4.3 and manually deleted all other system files associated with skype. Only deleted the .lck files in ~/.Skype, left the rest alone. Reinstalled 4.3

 

Still have the window coming up as Skype 4.1 and unable to connect. What else do I need to delete to get rid of 4.1 and get 4.3 working?

 

Side points:

1) You guys are quick to increase the prices and collect the money, how about you also give some warning to prevent gratuitous service interruptions?

 

2) Your engineers theoretically know your installation. If you can't have your installer package do a clean update automatically, why can't you provide a web page letting us poor customers know how to do it manually?

Message 6 of 260 (40,412 Views)
Routine Adventurer

EDIT2: Probelm Sovled. See Bottom of post...

 

I've removed from Synaptics 4.2 and installed using your download onto 12.04 Mint KDE 64bit. You can see Skype trying to start in the Panel but then it just dissapears. Nothing under syslog or any other log file shows any errors relating to skype.

 

I'vecheckt to see that my Firewall accepts Skype connections, and also tried it without the firewall.

 

As per another poster. Why change something that was working reasonably well?

 

How can I get this running?

 

EDIT.

 

I've alos tried removing the .skype folder. No success witt getting skype running.

 

When I run the installer, it tells me that all dependencies are satisfied, but I still only see the "install packages and cancel options. Shouldn;'t it say Skype Installed somewhere? To close it I have to click cancel or the X on the top right corner. I have Multiarch installed.

 

EDIT2: Try installing in the terminal using:

 

sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb

 See if you get any errors. I didn't.

 

Next run Skype using the terminal (not as root)

 

skype

 You'll then get a popup window "Skype Terms of Use". Confirm your langauage and click "I agree"

 

You'll then be asked to sign in.

 

Don't forget to check your Skype  "Options" after signing in.

 

So, now it's actually working for me.

 

Routine Adventurer

Seriously? I can think of better things to do on a Friday night, don't you know?  What does the checkbox "check for updates" do/did if it doesn't inform me of this beforehand?

 

You know, they have these new fangled things called repositories.  Heard of them?  How about trying them next time?

Novel Adventurer

Okay, had to terminate the running process in memory, forgot that closing the Skype window doesn't do that. 4.3 now working, with much less personal drama. The way I prefer.

 

edited to add:

 

And, FYI, got the following while posting. Knock yourself out:

 
An Unexpected Error has occurred.
  • Your request failed. We recommend you open a Lithium Support Case and provide the date and time you received the error and this Exception ID: 3FFF4A53.

    Click your browser's Back button to continue.

     

Message 9 of 260 (40,233 Views)
Casual Tourist

FUG_THE_NSA  - Thanks a lot for this, saved me a bit of research on a Friday nite.

 

Srsly guys, I was just freaking raging...