By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

RTX Dualphone can't sign in

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

I got  a message today from Hong Kong that they are aware of the problem and also from Skype:

Please be informed that Skype users in certain regions may have sign-in problem using Dualphone 3088. Skype is currently checking their servers. And we are waiting for their further update.

You can click this link to view Skype’s announcement:


If you have further queries, please contact us.




Best regards,

Canny Chan

Customer Support Officer

RTX Products Hong Kong Ltd

*edited for privacy*


By the way I did signed in last night at 5 AM and it worked for two minutes, so I hope Skype is working hard to fix this problem.

Let us hope they fix it soon .

Message 21 of 34 (2,551 Views)
Novel Adventurer

As I said in another part of the forum, going by past performance this is a Skype software issue and nothing to do with the handsets.  I and my daughter both have the same problem (in different countries!) using the older Netgear SPH200D dualphones (much better than the newer RTX Dualphone, having tried both).  The deafening silence from Skype since yesterday is also pretty much par for the course.  Last time it took several days for the issue to be dealt with by Skype.  It arose as a result of the Skype engineers fooling around with their software and not properly taking into account dualphone users.  Since it is only about 6 months since the last time this happened, expect the same again later this year, no doubt.

Message 22 of 34 (2,532 Views)
Novel Adventurer
Hi any news about Dualphone 3088? I still have problem with login..
Message 23 of 34 (2,417 Views)
Casual Tourist

Hi there,


Also still having the same problem, RTX dualphone with Belkin router.


Grateful for a response.

Message 24 of 34 (2,296 Views)
Novel Adventurer

same for me.  red light on skype box.  I have a dial tone, but can't dial or receive calls.  any ideas out there?  have done the usual - on/off, switched cables, etc.  darn skype support!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Message 25 of 34 (2,209 Views)
Casual Adventurer

HI! Well I dont use the Panasonic but the RTX 3088 which anyway is not a good phone as the sound is very poor, but for the rest its working ok. Now I use a VoipVoice phone and the sound is normal as if you were talking on a normal phone, I never use the RTX anymore because of the very poor sound. Now I installed Spype on my smartphone and it works also very well, and also with the video!

Sorry but I cannot help you! Try to reinstall Skype, maby that might help, I did it also one time and than after everything was ok! Signing out and reinstall completely, you want lose much, just your latest converstions! Good luck and let me know, kind regards, Wasili

Message 26 of 34 (2,199 Views)
Novel Adventurer

looks like microsoft is closing skype business, my rtx 3088 stopped working

Message 27 of 34 (2,135 Views)
Novel Adventurer

My RTX 3088 Dualphone was displaying "No IP address" for a couple of days before I notice it. I left it thinking it would correct itself but after a couple more days it still displays the same so I sign out and sign in. Now it seems to be signing in permanently. Can anyone help?

Message 28 of 34 (2,050 Views)
Casual Adventurer



I had the same issue with the RTX Dualphone 3088 and I succesfully contacted RTX support! They suggested to downgrade the firmware from version 250 to 245 and now all is back working! Menu- Settings - Advanced - Firmware update - All Firmware vers - Version 245.


Good Luck ;-)

Message 29 of 34 (1,862 Views)
Casual Adventurer
Have same issue ago 2014, did you get an answer?
Message 30 of 34 (906 Views)
Discussion Stats