By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Problem with Razer Megalodon in Skype

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

I recently bought a Razer Megalodon headset and the microphone does not work with Skype. If I go into "record" my computer picks up the sound and records it, but when I use the headset with Skype it does not record. If I try to call someone the error message is "Problem with recording device". I have the Audio settings set to Razer Megalodon for the microphone and speakers so that isn't the problem but I'm wondering what it could be?

 

Any help on this issue would be appreciated! (:

Message 1 of 10 (10,628 Views)
9 Replies
Novel Tourist
I am having the EXACT same problem and it is really frustrating!
Message 2 of 10 (10,445 Views)
Novel Tourist

Also having this issue.  Updated Skype.  Updated the firmware for the Megalodon headset.  My error swaps between Problem with recording device and Problem with playback device.  I found that Skype turns off my headset for some reason, but when I quit Skype, I'm able to hear and record on any other application.

 

Hunting for a fix has been very unsuccessful.

Message 3 of 10 (10,374 Views)
Casual Tourist

Same issue here. Can't find a solution. It's obvious my headset works. Just not with skype. I'm becoming disheartened.

Message 4 of 10 (10,350 Views)
Novel Tourist

same problemo over here. please fix!

Message 5 of 10 (10,309 Views)
Plo
Novel Tourist

I think I found a workaround! I was having the exact same problem; Razer Megalodon suddenly not working with Skype, despite the microphone and headphones working perfectly with everything else.

 

I think the problem has to do with the Razer Megalodon consuming too much power from the USB (your PSU doesn't have anything to do with it, it's a limitation of USB). I simply plugged the Megalodon into a powered USB hub (with no other USB devices attached to it) and Skype started working again without any problems.

 

Using a powered USB hub can solve other Megalodon related problems as well, such as if you try plugging in a Microsoft Xbox 360 USB controller into your PC at the same time as the Megalodon. They end up staving themselves for power unless you give the Megalodon its own seperate USB power source.

 

Anyways, I hope this helps you!

Message 6 of 10 (10,171 Views)
Novel Tourist

Tried hooking up to a powered usb port and now works like a charm! thanks

Message 7 of 10 (10,150 Views)
Novel Tourist

I have the same problem, however, I am for one not willing to go buy a power hub usb just because my device isn't compatible with skype anymore. It has been working before, skype just needs to do a hotfix. So please.

Message 8 of 10 (10,085 Views)
Novel Tourist
I plugged it in a powered usb hub and it now works again! thanks!
Message 9 of 10 (10,027 Views)
Novel Adventurer

http://community.skype.com/t5/Windows-desktop-client/Problem-with-recording-device-Razer-Megalodon/m...

over here it mentions you can just plug into the front of the computer if nothing else is there, which worked for me

Message 10 of 10 (7,799 Views)
Discussion Stats
  • 9 replies
  • 10629 views
  • 10 kudos
  • 10 in conversation