By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

My Microphone Doesnt work!

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Community Ambassador

Your image never came across in PM either.  Your Sony laptop uses the Realtek Chipset for audio.  Try downloading and installing the latest generic drivers which are newer than the ones on Sony's website.


If you are not sure if you have a 32/64-bit OS, just download the package with this name:

 Vista, Windows7, Windows8 Driver (32/64bits) Driver only (Executable file)


When you run it, it will usually remove your current drivers, reboot your machine, then re-install the latest drivers.  After 2 reboots, they should be up to date and you can try to use your headset again.


Message 11 of 13 (577 Views)
Novel Tourist

My logitech h390  mic will not work on skype...what's wrong with this? please help.

Message 12 of 13 (512 Views)
Casual Tourist

Mine doesn't either. I purchased a sony bravia LED Smart TV 48W590 and to use SKYPE on this product they recommended only the Sony CMU BR100 or Sony CMU BR200.  I purchased the BR200 and everything setup really easy but when testing this setup with my wife's PC Skype, I'm not getting any microphone audio from the BR200 (mike is not muted), yet doing the SKYPE Echo test, the mike test ok.  I've talked with Sony and all they could tell me is the unit must be defective and the only option is to replace it which I can, but that won't help me for XMAS morning skype with the grandkids(have backup on pc, but want to use the tv setup).  Also I found the SKPE software menus on the sony tv are considerably different  than what is in windows skype; i.e. missing permissions, tools, options etc.  WHY so different,?  Sony software is updated as double checked.

Message 13 of 13 (236 Views)
Discussion Stats
  • 12 replies
  • 2 kudos
  • 4 in conversation