By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

GE - SKYPE - Dect 6.0 Cordless phone doesn't complete skype out calls

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist



Two days ago, my skype phone model "GE - SKYPE - Dect 6.0 Cordless phone" stopped to complete calls. Weirdly skype (PC version) was with the same problem that day.

The call rings but when the other side answer, both sides can't hear nothing.

Today PC version is working normally however GE phone doesn't work anymore. I have tried other land numbers, but it doesn't work, people get the phone, but we can't hear each other.


I'm wondering if this kind of cordless skype phone has a expiration date of usage, even if is an old phone I believe that Skype should give support for this products. 


Coincidence or not, Skype has just announced a new GE cordless phone (GE Digital Cordless Expandable Telephone) 


I'm posing here because I can't find any other place to contact skype. 


Message 1 of 7 (3,904 Views)
6 Replies
Routine Adventurer

Have you tried taking out the batteries of the phone to force a reset and relog into skype?

Have you updated the phone to the newest software? Have you reset your router and modem?


Try all those first. My old Dect 6 is still working fine but any time I have had an issue one or all of those steps has always got it going again.

Message 2 of 7 (3,881 Views)
Casual Tourist
I was having problems with mine after using it for about 2 years without any problems. It kept reshowing the intro screen over and over every time I would take it out of the dock. So I gave it to my kids as a play phone having left it for dead. Today was cleaning up their toys and it was laying in the middle of the living room floor and because I really miss it and I figured "Why Not?", decided to try it again. Pulled out the dock, set it up, put the batteries in...same thing. So I grabbed a new set of rechargeable AAA's and popped them in...DOH! Works fine! I can't believe my kids (4 and 6 now) didn't destroy it! It's an extremely tough little phone, and I couldn't be happier that it's working again. This little phone is a tank; it's been dropped, kicked, left outside overnight (more than once), thrown in the toy chest and taken back out numerous times, and who knows what else (chewed on?). Now I'm going to have to explain to my kids why they can't have their play phone back! Aaron
Message 3 of 7 (3,791 Views)
Novel Adventurer

I thought I was in the same boat - initially the phone was working fine, then I couldn't complete some calls - I thought it was just toll free calls.  Now I come to realize that the first few calls worked fine, because the phone loaded my numbers from my skype account (they already had the +1 in front of the number) - my problem is a result of not dialing the +1 with my number.  As a result, the phone acts like it's making a call, but nothing results, no ring, no connection.  Good Luck All.

Message 4 of 7 (3,748 Views)
Novel Tourist

Same here. The phone is crap. I tried to reset the phone and it never ends. Now it's more than 14 hours waiting to get the reset finished without any result. The failure came all alone. Nothing change from my side, simply I stopped hearing the other part and the other part had the same issue with me. I have resetted the phone... and fully broken.  I tried to remove the batteries before with the same result. 90€ phone wasted... Thanks skype, you got me ¬¬

Message 5 of 7 (2,917 Views)

Hi, jcantos, and welcome to the Community,


I am checking into this on your behalf.


Best regards,


Was your question answered? Please click on the Accept as a Solution link so everyone can quickly find what works! Like a post or want to say, "Thank You" - ?? Click on the Kudos button!
Trustworthy information: Brian Krebs: 3 Basic Rules for Online Safety
Message 6 of 7 (2,908 Views)
Reliable Adventurer

Hi jcantos,


Please be assured that your GE Phone is covered under a 12 month warranty and if the unit is deemed as defective, eBuyNow will reship them a new unit at no cost.


Before taking further steps please allow us to give you this troubleshooting to see if we can help you with your problem. Please ensure that the handset is within range of and linked to the base station. This is necessary for the telephone to charge.

When you put the handset into the charging cradle, you should see the following:

1. Charge indicator (RED LED) will light up permanently until the handset is lifted out of the charging cradle.
2. Handset initially displays "charging" within several seconds when the battery is low.
3. Handset will display scrolling battery icon for charging.

Please let us know the following:

1. Is the RED LED always off? Check if the handset charge pin really contacts to the charge cradle spring, as well as to verify if the sub-adapter connection is loose or not.
2. Is the battery not installed well? The handset will display "no battery".  Disconnect and re-connect the battery pack into your phone.
3. Does the handset display "charging"? Wait a few minutes.  If the handset starts to enter into stand by mode with the scrolling battery icon, the handset can be charged up.
4. Does the battery icon on the phone indicate battery low, but when put in the charger, indicates battery is fully charged?
5. Have you managed to successfully make a call from the handset?
6. Is the indicator light on of your base station?

The more information you can provide us with, the better we can assist you.

If you already went over the above and are still having problems, please contact our eBuyNow's Support team by visiting  (add the http:// as this forum does not allow hyperlinks)  and one of our agents will gladly assist you.



Message 7 of 7 (2,904 Views)
Discussion Stats
  • 6 replies
  • 1 kudo
  • 7 in conversation