By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

GE Dect 6.0 doesn't ring on incoming calls

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist

I have been using the GE Dect 6.0 for two years, more or less successfully.  Two days ago it got stuck on a single screen so I removed the battery and restarted it.  I am able to make calls, but now when someone calls me, it only rings on my laptop but not on the phone.  This happened before but I cannot find out how to change this setting.  I tried using the Chat feature and the guy told me to call Amazon!!!!!!!!

Help!

Message 1 of 2 (629 Views)
1 Reply
Community Ambassador

Have you tried following the procedures in the manual?  I have attached those sections below:

 

 

 

 

 

Message 2 of 2 (623 Views)
Discussion Stats
  • 1 reply
  • 630 views
  • 0 kudos
  • 2 in conversation