By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Freetalk Connect me adapter reboots during calls

Go to solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

Yes- its not the phone

Novel Adventurer

debating returning the item or filing a claim

Former Staff

Of course you can contact Freetalk and request to return your device.


There are just a few that we are aware of that are having this kind of problem. We're working hard to try to reproduce it but unable to so far - we've made calls both to landlines and other Skype users many hours in length.



Novel Adventurer

I have the exact same problems!

No external line, only using internet.

Software is v

I've just made for test phone calls to my cell phone. The Freetalk Adapter BOTH drops calls and restarts.


Of my 5 phone calls 4 dropped. Here are my results:


#1 Dialed and answered successfully, dropped after 10 seconds to dial tone.

#2 Dialed and dropped (to dial tone) just as I was about to answer.

#3 Dialed and connected ok. Let the connection continue for 3 minutes and disconnected. No idea how long it would have been ok for.

#4 Dialed and dropped (to dial tone) just before it started to ring.

#5 Dialed and it began to ring. I picked up the phone and there was no audio. After about 5 seconds, I heard a click on FreeTalk phone and looked at FreeTalk box and it had gone solid red, then blinking green, then solid green.




Casual Adventurer


Tried another phone as well, but no change.  We've done everything on the list.  Hardware reset, software upgrade, power is on a UPS, swapped phones, swapped freetalk devices etc.   The only thing I can think of is that there might be some incompatibility with some brands of routers.   We are using a Linksys E1000 router at my friends who I recommended this to who is having all the rebooting trouble.   I am using an older Linksys router and a different ISP and have no trouble.     Could it be something with the ISP or the router?    My friend is about ready to return it for him money back, but I would really like to see it work for him as I love it when its working.

Novel Adventurer

I am having similar issues except mine is much more consistent.  I get dropped calls after about 30 seconds consistently on every call.   This started with one of the recent firmware updates, I believe the firmware update just before the current firmware version perhaps 1.05.5 in late October 2011.   The adapter was not doing the drops prior to that.

Casual Adventurer

I've noticed a lot of people have commented that AFTER they have done the update is when the problem of rebooting started.    For all those people having this trouble I wonder if somebody at freetalk can look to see what was changed that could have resulted in the rebooting problem for a percentage of the people?  or offer the old software version to download and turn off the updates to make the device even useable for some.    My friend who is having the trouble I've swapped freetalk devices with him and his device works perfect for me and mine which worked perfect is now doing the rebooting for him.   We've replicated everything on both sides as a process of elimination in troubleshooting the cause and the only things left that are different is he has a different ISP and network router.   I suspect the router or some setting of the router so that will be the next to eliminate as the cause if support can't come up with a solution.

Novel Adventurer

I have also been experiencing the same problem since it was plugged in.  Dropped calls inbound and outbound after a few seconds.  Tried different phones with same result.  Line is dead unusable for numerous seconds after call has been dropped and then tone comes back.  Firmware version, last updated on 11-19-2011.  

Casual Adventurer

Does anyone know if they have withdrawn the firmware.  My unit is stuck on and I assumed I had a problem with the upgrade process.


I'm wondering now if they've just withdrawn the new firmware.

Novel Adventurer

As of 2 days ago they were still on because they had me do a reset and my unit reloaded that same version... with the same problem.  They are mailing a new one.

Discussion Stats