By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Freetalk Connect me adapter reboots during calls

Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

My freetalk connect me adapter has rebooted on several occasions during calls. The call would drop and the LED on the adapter would turn solid red. It would stay red for several minutes, then turn to a flashing green, and finally to solid green. I would then be able to make and receive calls again. I have tried doing a factory reset and also changed electrical outlet. Neither helped. This seems to have started after my unit updated to software version 1.5.x (although I am not absolutely certain). Has anyone else seen this problem?


1 Accepted Solution

Accepted Solutions
Casual Adventurer
Accepted as a solution by RayG
‎28-08-2015 11:00

I wish this solution would have come earlier.

FreeTalk had promised that they would send a replacement adapter to me within 20 days. 20 days came and went with no adapter showing up.  I had to contact FreeTalk to find out that there was a problem with the shipment and that they had decided to credit me back the money instead. The only hint of what was going on was a credit showing up in my checking account. No email, no letter, no phone call.

I still love Skype and I will continue to use them when on my laptop. As far as the FreeTalk adapter and my SkypeIn number ...I switched to Vonage. Once FreeTalk works out all the bugs with the adapter and improves their customer service I will consider  switching back.

View solution in original post

Message 49 of 53 (1,003 Views)
52 Replies
Former Staff

Thank you for informing us, sorry you are having problems.


We're pretty sure we've managed to locate what is causing this and are working on releasing an update as soon as we possibly can.



Message 2 of 53 (2,003 Views)
Novel Adventurer

I believe I'm having this same problem, though I haven't actually had it drop me on a call yet.  However, the Freetalk Connect me adapter is constantly rebooting.  About every 15-20 minutes the red light starts flashing for 3-4 minutes, then it turns red, and finally back to green.  During the time it is red (flashing or not), I do not get a dialtone.  When it does return to green then I can make/receive calls once again.

Message 3 of 53 (1,989 Views)
Former Staff

Flashing red = software updating.


What version software do you have?



Message 4 of 53 (1,986 Views)
Casual Adventurer

I got software update on the 15th. My adapter rebooted again while i was making a call on the 16th. Was this the update to fix the reboot problem?

(I went ahead and reset the adapter for a 2nd time to factory settings)

Former Staff did resolve an issue that related to rebooting during a call and was tested extensively on long (several hours) calls. Did it actually reboot or is it possible that the call dropped for some other reason?





Message 6 of 53 (1,964 Views)
Casual Adventurer
i checked the adapter when the call dropped and the led was solid red..then it went to flashing green, them solid green. would that happen if a call dropped for some other reason other then the adapter rebooting?
Message 7 of 53 (1,949 Views)
Novel Adventurer

I too am having problems with dropped calls, though have never checked the lights after a call was dropped.


Is this information useful to post?

Message 8 of 53 (1,942 Views)
Casual Adventurer

Hi there,


I have a similar thread going in the mobile topic (where I had found other FreeTalk Connect issues).


I have been having dropped call problems as well.


Initially it was like yours - the light went red, then flashing green then green which seemed to be some kind of reset.


There was then an update ( I believe) and the problem changed.  Now it is dropping calls after 15 - 20 minutes.  No warning - it just drops.  The green light remains on and I can dial another call at that point.


I got the update on 11/14/2011 which I thought was supposed to fix the dropped call symptom and I thought it might have yesterday (11/16) when I started using it again.  Unfortunately, it's back to dropping calls this morning.


I've reported these issues via the support site as well.


I was hoping to use this device for a business phone but that's obviously not going to work out since it is not reliable at all.


Message 9 of 53 (1,915 Views)
Former Staff fixed an issue which was causing the device to reboot (and therefore drop the call). If the green light is staying on and the call is dropping, this is a different issue. Do you hear any sound when the call drops? The calls you are making - are they to a telephone number (SkypeOut), or a Skype to Skype call, or is someone calling you on a SkypeIn number? Any details like this can help us to try and pinpoint the problem that you are having. What type of network are you connected to - adsl, cable etc? Call dropping is often a symptom of some kind of network problem - has anything changed in your network recently, or other people using it?



Message 10 of 53 (1,911 Views)
Discussion Stats