By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Cordless Skype Phone - device not working in Windows Vista SP2 at cold boot - but replugging works

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

I purchased a new Skype cordless phone (this one). The phone requires use of a program called SkypeMate, but is marketed as not needing specific drivers. Basically, at cold boot, the cordless phone fails to work correctly.


  • Initially, the taskbar popup appears which states that there is an unrecognised USB device
  • SkypeMate says that the USB cable needs to be connected in the system tray
  • The phone's handset display just continues to show the USB logo (the pitchfork), just as if I hadn't powered up my computer i.e. it looks like it's never given a signal to "wake up"
  • In the Windows device manager, my cordless phone is listed, but it has the telltale yellow problem icon, and its status is given as "This device cannot start. (Code 10)" in the details
  • In USBDeview.exe, the device is "Connected: No", "Disabled: No", "Safe to unplug: Yes" at Port_#0004.Hub_#0001

... yet removing the phone's USB cable and plugging it back in makes the device work perfectly, every time. I can make calls, receive calls, it's all great. And if I then reboot, the phone works fine too, until the next time I power down my computer and do a cold boot, e.g. the next morning. ARGH!


(This is especially frustrating since I intended Skype to be used for a family member who isn't technically savvy at all, I just wanted to let it all load automatically after I set it up.)


Other points of note:

  1. Looking in USBDeview, I can see that once I literally replug it in, the phone is listed as a USB Composite Device, using Microsoft USB Generic Parent Driver v6.0.6002.18005.
  2. The cordless phone is plugged directly into my computer, not via an external USB hub. All other devices work correctly when using this port. The other items plugged into the in-built USB hub on the tower are my mouse, keyboard and headphones. The power level to this USB hub is 500 mA, at least that's what's given in USBDeview.
  3. SkypeMate is the latest version (v5.0.0.7, device version 0ACB), and Skype is the latest too (v5.5.0.124).
  4. My motherboard's BIOS screen has an option to say "yes" or "no" on whether the OS supports plug and play. Toggling this between the two options doesn't seem to make any difference in behaviour. Note that my MOBO BIOS version is the most recent.

Anyway, to resolve this, I did a little batch script that runs on me logging in - you know, basically just mimic the unplug/replug action for me. But that doesn't work, I've tried a few things e.g. disable/enable that particular port, or even remove the internal hub and rescan for hardware - none of that works.


     echo Removing the 4-port internal hub...
     C:\devcon.exe remove *ROOT_HUB20*

     echo Rescanning for hardware

     devcon rescan

     echo Waiting for 30 seconds

     ping -n 30 -w 1000> nul

     echo Try a disable/enable toggle...

     C:\USBDeview.exe /disable Port_#0004.Hub_#0001
     C:\USBDeview.exe /enable Port_#0004.Hub_#0001
     echo Finished!



  • Can anyone tell me how I might begin to resolve the fact that my cordless phone doesn't work on a cold boot?
  • ... or, failing that, some sort of idea on how I can mimic the physical replugging of the phone's cable? I've done extensive reading on this but can't get this "Plan B" idea to work
2 Replies
Novel Adventurer

Okay, I've also found this Error Report in the Windows event viewer, if it helps to troubleshoot:


Log Name:      Application
Source:        Windows Error Reporting
Date:          11/03/2012 19:06:34
Event ID:      1001
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      omega-desktop
Fault bucket 601134676, type 5
Event Name: PnPDeviceProblemCode
Response: None
Cab Id: 0

Problem signature:
P1: x86
P2: usb\class_01
P3: {4d36e96c-e325-11ce-bfc1-08002be10318}
P4: 0000000A
P5: usbaudio.sys
P6: 6.0.6002.18005
P7: 04-11-2009

Attached files:

These files may be available here:
Event Xml:
<Event xmlns="">
    <Provider Name="Windows Error Reporting" />
    <EventID Qualifiers="0">1001</EventID>
    <TimeCreated SystemTime="2012-03-11T19:06:34.000Z" />
    <Security />


Upon checking C:\ProgramData\Microsoft\Windows\WER\ReportArchive\Report14447b58 I found this file report:


Sig[1].Name=Hardware Id
Sig[2].Name=Setup class GUID
Sig[3].Name=PnP problem code
Sig[4].Name=Driver name
Sig[5].Name=Driver version
Sig[6].Name=Driver date
DynamicSig[1].Name=OS Version
DynamicSig[2].Name=Locale ID
FriendlyEventName=Could not load driver software
AppName=USB Audio Device
ReportDescription=Windows was able to successfully install device driver software, but the driver software encountered a problem when it tried to run. The problem code is 10.

Novel Adventurer

No one / anyone?

Discussion Stats
  • 2 replies
  • 0 kudos
  • 1 in conversation