By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype Community has moved

You can find the new Skype Community here. For more information please read this post.


Novel Adventurer

why do my SMS not show up with the phone number?  the only appear with the 5 digit number (the same 5 digit number if sent from either my phone or computer and seperate skype accounts.)


Does anyone know how to set this so my skype phone number appears in text messages?

Flag for a Moderator
Message 1 of 6
5 Replies
Novel Adventurer

I still cannot figure this out.   Why does my skype number not appear when I send a text?  I have two account and the both show up with the same ###-## (format) If I send a text using another computer or my Iphone from either account, its the same 5 digit number but not the skype phone number.   


So, how do I get the caller ID to ID my skype phone number or my name when send a SMS?

Flag for a Moderator
Message 2 of 6
Novel Tourist

I too have been having this same exact problem for a long time now. When I first verified and added my cell phone number to the system, it worked fine. But for many months now, when I go to send an SMS from my Skype account, it still shows me that it will appear to the receiver that it is coming from my cell phone number, but when I send the SMS, it shows up with this meaningless 5-digit number. A few minutes ago, I added another cell phone number of mine to my setup and tested it. Again, it shows that it will appear to the receiver that it came from my new cell number, but when the message is sent, the receiver gets this meaningless 5-digit number which they cannot respond to. This is very frustrating. I now have verfied two cell numbers and neither one of them works properly. How the hell do I send this support problem to Skype technical support. This is rediculous.

Flag for a Moderator
Message 3 of 6
Novel Adventurer

I would even welcome the screen name showing up if I cannot get the phone number to appear, though I am trying to get my skype online number to show up.  As it is, even when I turn off the caller ID it still shows up with that 5 digit number, no mater which device I send it from.   


Is it just the two of us who have this problem or just no one knows out to fix it? 



Flag for a Moderator
Message 4 of 6
Novel Adventurer

There are a lot of frustrated people with this issue out there... I have finally found the answer hidden away in Skype help:


"Text messages sent to mobile phones in China, Taiwan, Canada and the USA will not display your Skype Name or a validated mobile number. Instead, these text messages will have generic, pre-defined numbers as the sender ID. For texts sent to mobile phones in Russia, the Skype Name is not displayed. A generic number is displayed unless you have set your mobile number as the sender ID" (see help page here)


Sorry people - it's frustrating and I have no idea why it would be this way, but that's the way it is

Tags (1)
Flag for a Moderator
Message 5 of 6
Casual Tourist

I'm not sure who's design prohibits SMS ID, Skype, Microsoft or US govt.  I've tried to ask Skype on-line chat, but the 'live' person doesn't quite pass the Turing test. 

Flag for a Moderator
Message 6 of 6
Discussion Stats
  • 5 replies
  • 2 kudos
  • 4 in conversation