By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Online Number always busy? And is NOT

Honorary Adventurer

Have you tried this.


First check that your privacy settings are set to ''Allow calls from anyone''.
Then change them to "Allow SkypeIn calls from Only people from my Contacts List".
Save and wait for 5 minutes.
Log out from your Skype account and log back in.
Change settings back to "Allow calls from Anyone".
Save and wait for 5 minutes.
Log out from your Skype account and log back in.


If you found a post useful, please give Kudos. If it helped to fix your issue, mark it as a solution to help others.
Thank You!
Message 11 of 15 (3,501 Views)
Novel Adventurer

Did that work for anyone? It did not work for me!!

Message 12 of 15 (3,478 Views)
Novel Tourist

ARRRRRGGGGGGHHHHHH. Me too. Will Skype ever listen? WHY are we paying for this non-service?

Message 13 of 15 (3,471 Views)
Casual Tourist

Same problem here! I want a FULL refund, please! The worst thing is that I made business card with this number and now I am also loosing my business  cards money because the number is busy?!


I want my money back!!!!!!!!!!!!


Message 14 of 15 (3,454 Views)

Hello everyone,


If you purchased Online Number and it's not working then follow these steps:


1) Make sure number is active and delivered on your account page:


2) Ensure you have set up privacy settings correctly as shown here:


3) If number is dialed correctly and it is still not working then contact customer service


Tip: It helps if you have following info:

- failed call date/time

- phone number you made the call from



If answer was helpful please mark it with Kudos and if issue is resolved mark it with solution. This will help other users find this answer more easily. Thanks in advance!
Message 15 of 15 (3,448 Views)
Discussion Stats