By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

spam calls

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

All my Privacy settings on both computor & my Android phone show that i can receive voice/video Calls & IM from my contact list ONLY yet today i received 3 sex spam callers, they were not on my contact list, they did not request an Add and i have no idea who they were but they were obviously sex spamers, i cannot have this AT ANY TIME.

 

As soon as i hung up they called again 20 times within 1 minute. this has happned 3 times today already.

 

i could blockthem but that will not solve the issue that all my setting allow for my contacts alone to contact me so i should not be getting this in the 1st place.

 

Can anyone help me?

 

regards

 

Jackie

Message 1 of 9 (1,178 Views)
8 Replies
Highlighted
Novel Tourist

Hi, I have had exactly the same problem. I've also found that these 3 callers are not in my contact list so I am unable to block them. There is no record of them on my laptop only on my android ... how wierd is this and how on earth do we prevent this??

Message 2 of 9 (1,071 Views)
Novel Adventurer

Hi, I have the same problem as well.  I got a bunch of people that I do not know then but chatting in the group chat...what is happening with Skype???

Message 3 of 9 (1,068 Views)
Novel Tourist
Yeah, I can confirm I'm having the exact same problem. And it only shows on Android Skype. Even after I set myself to invisible, some loser kept spam-calling me over and over again. But I got like a dozen tards contacting me in less than half an hour.

Skype on Android is getting to be more of a pain than it's worth. It's already way too easy to accidentally make regular/video calls or answer ones with your contacts, which is way bad enough, but now with strangers? I think I'm done.
Message 4 of 9 (1,042 Views)
Novel Adventurer
Having the same problem!!!! What else do I do to stop this from happening?!?!?! Already uninstalled the thing twice.... Seems to be Arabic people....
Message 5 of 9 (1,039 Views)
Tourist

My mom is facing the same thing.She is very concerned about this and this is really embarassing to her.Please take actions against this immediately.

Message 6 of 9 (1,005 Views)
Casual Tourist
Check your settings again. My wife had this problem as well and we found that Video Calls was still set to anyone. Make sure everything is set to CONTACTS ONLY...there are three or four places for this setting to be enabled.

Hope it help you out as well.
-Screwba
Message 7 of 9 (900 Views)
Novel Tourist

SAme thing happened to me. I already checked in the preferences and is everything set to contacts only

Message 8 of 9 (834 Views)
Novel Tourist
I am experiencing the same problem. Why is Skype not responding to the issue!?!?!?!?
Message 9 of 9 (822 Views)
Discussion Stats
  • 8 replies
  • 1179 views
  • 4 kudos
  • 9 in conversation