By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

WiFi Proximity Bug - Please fix, it is simple

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Reliable Adventurer

All people here knows that most of Android phones have sound choppy in the skype voice call. This appears when proximity sensor is triggered (when you take your phone close to ear). This appears when you make call through WiFi connection (not 3G).

 

I research problem and found why this bug appears. Problem related to WiFi connection. Most of android phones switch WiFi module to PSP mode when display is off, to save battery power. 

You can read this thread about this problem: code.google.com/p/android/issues/detail?id=9781

 

I was do a little test and this problem was confirmed:

1) connect charger and make skype voice call with touch proximity sensor to get screen off, result: no sound choppy at all! Sound is good! But you need charger to be connected...

 

Comment: android phone dont switch WiFi module to PSP mode when phone connected to charger

 

2) disconnect charger and start skype voice call, run ping to the phone from PC and get the following results:

Pinging 192.168.1.240 with 32 bytes of data:
Reply from 192.168.1.240: bytes=32 time=1ms TTL=64
Reply from 192.168.1.240: bytes=32 time=1ms TTL=64
Reply from 192.168.1.240: bytes=32 time=1ms TTL=64
Reply from 192.168.1.240: bytes=32 time=1ms TTL=64

 next, I touch proximity sensor with finger to trigger screen off and results was changed:

Reply from 192.168.1.240: bytes=32 time=1ms TTL=64
Request timed out.
Request timed out.
Reply from 192.168.1.240: bytes=32 time=122ms TTL=64
Request timed out.
Request timed out.
Request timed out.

 next, I leave my finger to screen on and get the following change:

Reply from 192.168.1.240: bytes=32 time=8ms TTL=64
Reply from 192.168.1.240: bytes=32 time=1ms TTL=64
Reply from 192.168.1.240: bytes=32 time=1ms TTL=64
Reply from 192.168.1.240: bytes=32 time=1ms TTL=64
Reply from 192.168.1.240: bytes=32 time=1ms TTL=64

 

Most of android phones have this issue: HTC, Google, and other

 

Problem appears when you make voice call through WiFi connection on Android 2.2. Android 2.3 has fix for that, but 2.3 is not avalilable for most of existing android phones.

 

Skype developers can fix that problem with very simple trick - just add option in skype settings to disable proximity sensor use. And this option will help Millions android skype users to solve sound choppy problem!

 

You can looking for another good workarounds of this proximity/WiFi issue as long time as you want.

But first, please, add option to disable proximity sensor during voice call and Million of peoples will thank you! Just add option to display always on during voice call, Million of peoples needs that thing to get possibility of use skype voice call.

 

Please make patch with option to disable proximity sensor (the same like it works when loudspeaker is activated). Please!

 

Thank you!

Message 1 of 12 (2,936 Views)
11 Replies
Casual Adventurer

Coudln't Agree more. I have the same annoying problem ever since I bought my HTC Desire HD.

Please Skype fix this annoying bug, All other voice chat applications dont have this issue!

Message 2 of 12 (2,572 Views)
Experienced Adventurer

This bug can be fixed just in 5 minutes, its very simple - add option to disable display turn off feature. But we're waiting more than 2 month for that fix. Skype know that bug. Two updates released, but critical bug still exists! Fantastic! 

Message 3 of 12 (2,546 Views)
Experienced Adventurer

We're still waiting for critical update for proximity sensor bug

Message 4 of 12 (2,532 Views)
Experienced Adventurer

We are waiting for BUG FIX for 2 month

Message 5 of 12 (2,521 Views)
Highlighted
Community Manager
Thanks for the report. I've forwarded your complaint but I can't comment on when it will be addressed.

Currently as a workaround I'm suggesting to use a headset.

Found a helpful message? Give it a Kudo below to say "thanks" ¦ Latest Community News
Did my reply answer your question? Accept it as a solution to help others, Thanks.
Message 6 of 12 (2,511 Views)
Novel Adventurer

Hi, what is the current status on this as it's still broken in the latest version of Skype?

Message 7 of 12 (2,243 Views)
Reliable Adventurer
this bug still exists in the latest skype. But I found good workaround. I make s-off and root my phone and replace wifi driver with custom version, this driver didn't switch off in low power mode.
Message 8 of 12 (2,232 Views)
Novel Adventurer
Thank you. The earphones are a good solution plus please address this issue asap.
Message 9 of 12 (2,021 Views)
Novel Tourist
Pffffffffffff
Message 10 of 12 (1,788 Views)
Discussion Stats
  • 11 replies
  • 2937 views
  • 5 kudos
  • 9 in conversation