By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype problems with Samsung Galaxy s4 phone and Vodafone mobile internet, UK

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

Skype does not work at all in Samsung Galaxy s4 phone with Vodafone UK mobile internet, even audio calls. Skype with wi-fi is perfect at the same time.

Both Samsung and Vodafone UK deny problems with device or mobile internet.

Maybe, Skype for Android is not compatible with mobile internet in Samsung Galaxy s4?

Does someone have the same problem?

Message 1 of 22 (20,755 Views)
21 Replies
Novel Adventurer

I have ATT Galaxy S4. 

- Skype is extremely slow on contact search.

- The voice quality is poor.

- Could not find ways to use Bluetooth to answer call 

Message 2 of 22 (20,640 Views)
Novel Tourist
i went video call but this phon not video call proplen if you phon good but i went video call fece to fece my fmlly plz
Message 3 of 22 (20,601 Views)
Novel Tourist
Hi I got the same problem with gs4 nd iam using vodafone internet connection in india.it works well when connected to wifi but dosent work when connected via mobile internet.is ther any solution to the problem
Message 4 of 22 (19,715 Views)
Hi i have same problem samsung GS4 with 3 network my skype video not working i call nepal i can c them but they can't c me is there any solution fix it?
Message 5 of 22 (18,796 Views)
Casual Adventurer

Same problem here. After this forced upgrade Skype does not work at all on Vodafone or wifi. After the upgrade audio on the S4 speaker was wisper low and unusable. Now a few days later after login there is only a Skype busy message. Such a premature upgrade release only generates bad feelings. 

Message 6 of 22 (18,307 Views)
Novel Tourist
Worst connection ever. Calls last 45 sec then disconnect. Can keep doing this many times. Very frustrating. Did expect more than this.
Message 7 of 22 (17,663 Views)
Novel Adventurer

Also having this problem - skype connects when wireless network is available, but does not connect when using mobile phone data plan. I am with Amaysim on Optus network. 

 

Noticed there are a lot of the same question on this forum - does someone actually reply to these? Please send me the link on how to fix if there is one.

Message 8 of 22 (17,251 Views)
Novel Adventurer

I don't know why skype does not connect when using data - I had the same problem using Optus in Australia.

 

After a whole day of trawling around the net about the different mobile network modes in S4, I found this way of overriding the wifi settings on your phone to default - and skype then worked.

 

From the homescreen : Menu (button) > Settings > More networks > Mobile networks > Access Point Names > Menu (button) > Reset to default

 

If it works for you, do let me know pls.

Message 9 of 22 (17,222 Views)
Novel Tourist

Thank you cc2014, this was driving me crazy. My APN was set for some reason to WAP instead of Internet cofiguration (Orange Romania). I know is a bit unrelated to the topic but just wanted to say thanks.

Message 10 of 22 (14,855 Views)
Discussion Stats