By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype on Samsung Galaxy S3

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist
Having the same problem with my new s3...very unhappy. seems to only work - sporadically - if you turn off wireless option on the s3. even then, it failed on me midway thru a call.
Message 41 of 177 (8,710 Views)
Novel Tourist
How do i add a contact ?
Message 42 of 177 (8,679 Views)
Novel Adventurer

Tango worked perfect!  Quality is about the same as Skype, but at least it has been updated for my Samsung!  To H*** with Skype!

Message 43 of 177 (8,665 Views)
Novel Adventurer
There is an even worse issue for the s3... I have redownloaded the file and the issue has changed.. I occasionally get the invalid password error, and that can be fixed by loggin into Skype from another device and then loggin out from that other device and restarting Skype on your s3 (considering you closed it from the settings>application manager area.. Then once I am able to log on NONE of my Skype contacts show up, when I attempt to search for my Skype contacts their names won't show up, when I search names on the Skype directory also they will not show up.. Haven't been able to fix this one.. Also when calling someone the screen says "calling" and doesn't change to ringing once it is ringing... That feature is a huge benefit because it may just be lag that will show contacts online sometimes but if it says ringing their device in my experience has been on.. Also the Bluetooth issue, I would think this would be a big upcoming issue with how hard the s3 is being pushed into customers heads... I have plantronic Bluetooth wireless headphones which work great.. Except on my s3, iPhone 4 were alright though. A trick if anyone is having that would be switch to the headset first ( even I it's already set to headset) then switch to Bluetooth f it shows. That should kind of fix a glitch. Hope this helps someone
Message 44 of 177 (8,646 Views)
Casual Tourist
Its ok
Message 45 of 177 (8,640 Views)
Novel Tourist
Hi
Message 46 of 177 (8,605 Views)
Novel Adventurer
Hi? Do you know how to fix any of this??
Message 47 of 177 (8,598 Views)
Novel Tourist

Works on Galaxy S3(VZW) to Mac laptop (unknown model - bought in 2011). If you don't see the option to video chat you might need to go into settings and enable it (I was given a warning my device wasn't certified as others but it works nonetheless.

Message 48 of 177 (8,587 Views)
Novel Adventurer
That is shame skype is not working on galaxy s3
Message 49 of 177 (8,474 Views)
Novel Adventurer
That is shame sk
ype is not working on galaxy s3
Message 50 of 177 (8,474 Views)