By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Samsung Galaxy s3 video calls on skype

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer
My galaxy s3 skype video calling is not working for calling other android phones it works but for laptops doesnt how to fix this problem
Message 31 of 114 (15,559 Views)
Novel Adventurer
Hey guys, I hope you all have gotten your issues resolved with Skype but if not here is a bit of know how! First no company not even the mighty A
Message 32 of 114 (15,274 Views)
Novel Adventurer
Sorry... Let me continue! Not even the mighty Apple can block Skype it illegal to do so! But what should be looked at is the network which should be on wireless for the best use while on Skype! As for the video not working and you having to set it is the fault of the person who sold you the phone not properly doing their jobs!!! You can download an app called 4share and look for the 3G to Wifi app. Make sure any app you download from 4share has APK at the end of it otherwise it will not load! Also look for 3G enhancer. I've worked on both iPhone and android and like android more as iPhone is over rated and that's a fact! But if you have a question feel free to ask if its pertaining to androids I will give you the best and complete way if possible and if I know if I don't I will say so not like a bunch of ass wipes that want to ask a lot of questions only to give the wrong answers!
Message 33 of 114 (15,270 Views)
Novel Adventurer

I have the same problem.  Weird colors and very poor audio (On both ends).  Verizon tells me it is a SKYPE problem and they need to fix.  I have installed and reinstalled the program several  times and get the same problem each time.  I cannot understand why Microsoft in all the wisdom cannot fix this problem.  Could it be that they are concentrating on their own windows OS system?

Message 34 of 114 (15,260 Views)
Novel Adventurer

From my point of view (being a novice), it appears both Verizon and Skype (Microsoft) is giving us the runaround.  Verizon blames Skype and Skype will not even reply to compaints.  A really sick situation for the comsumer........

Message 35 of 114 (15,257 Views)
Novel Adventurer
Hello,
With m'y new version of Skype, all works perfect. I see the video option.

regards

Jnl
Message 36 of 114 (15,252 Views)
Novel Adventurer

Christopher 7026 you are the God-blessed genius of the Skype Community!  I have been sitting here at my computer in Manchuria (I am from Florida; why i'm here is another story)trying to figure out why my new Galaxy S3 super fancy expensive gizmo does not do video calling on Skype.  I even researched downloads that are for much more primitive versions of Android.  Low and behold, I follow your instructions:  I first sign out of Skype.  Then I go to "Settings," and then "Applications," and then find the Skype program.  I select it and the data screen pops up.  I do a "Force Stop," just like you said.  I then push "Clear Data," and all data is gone.  I then go back out of Apps, open up Skype, and login with Skype name and password.  Eureka!  I am video call enabled!  I don't know WHAT the problem was.  All I can say is Skype was loaded on at the store for me by the salesman.  I did not load it myself.  That should have no effect on anything, but just to let you know.

    Dinner and drinks on me anytime you show up in Changchun.  Thanks again. Mitchk97

Message 37 of 114 (15,075 Views)
Novel Adventurer
I did force stop, cleared data, restarted Skype; was warned my phone was not "Skype certified," then logged in to Skype. Eureka! I was video-enabled!
Message 38 of 114 (15,072 Views)
Novel Tourist
i use samsung s3 and recently i downloaded skype. unfortunately there is no icon for video call.. only icon for voice call and sms.. could someone please help me.. thanks
Message 39 of 114 (15,003 Views)
Novel Adventurer

Log out of Skype; go to apps, go to settings, go to Application Manager, make sure you select "All" once you are in App Manager; scroll down to Skype and select, select Force Stop, select Clear Data after that; go out of Apps and back to home screen, log in to Skype; if video icon appears after you are logged in then problem solved--good, cheap, and plenty!

Message 40 of 114 (14,983 Views)