By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Samsung Galaxy s3 video calls on skype

Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

still doesn't work, even after enabling video calling

Message 11 of 114 (19,034 Views)
Casual Adventurer
I did hard reset on my and is working right know
Message 12 of 114 (19,026 Views)
Novel Adventurer

Hi everyone, i am getting a quality issue on skype calls. on the same connection the video quality transmitted via Dell or my IPOD is thousand times superior to the quality of galaxy s3. other person sees pixel blocks when i am talking on the SGS3, and sees my crystal clear pic on Dell Laptop or IPOD. why is that so? Galaxy S3 certainly is capable of capturing better video even from secondary camera. 

Message 13 of 114 (18,927 Views)
Novel Adventurer
This problem is mislabeled as 'solved'. Redownloading, enabling video calls still does not work. Maybe it had to do with the message from Skype that this device is not certified.
Message 14 of 114 (18,840 Views)
Novel Adventurer
Yeah incompatible and not upto par... i just said even my ipod transmits 480p consistent video.... it feels so useless at hand.
Message 15 of 114 (18,805 Views)
Novel Adventurer

 "Maybe it had to do with the message from Skype that this device is not certified."


That is my theory since that message puzzled me from the start. Dont understand WHY the device is not supported. Would like an explanation for that. 



Message 16 of 114 (18,477 Views)
Novel Adventurer

I think I know what's going on, I had the same problem, and I corrected the problem, its work!!
So .... First, logout from Skype on your computer
Secondly .... open up your phone on the seating, and aplication manager, and Skype icon ... Clik Force stop and next Clear date
Start Skype again and log on.
Fix a problem

Message 17 of 114 (18,183 Views)
Novel Adventurer

Nope does not solve the problem, the video transmitted is still highly pixelated, as if talking on an old .3 MP camera, my laptop has a far far better (480p) quality and seemingly looks very good as DVD. but on my S3 it looks very odd..

Message 18 of 114 (18,159 Views)
Novel Tourist
I Have the galaxy s3 on att&t and video calling is enabled in settings, and but no option to video call someone. Maybe it is too new a phone and a Skype update is needed?? Help!
Message 19 of 114 (17,984 Views)
Novel Tourist
I had the same problem with my galaxy s2 and now with galaxy s3 have i again the same problem. Skype please help us with the video quality on galaxy s3
Message 20 of 114 (17,594 Views)