By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Samsung Galaxy S2 and skype

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

Please help,

I recently installed skype on my Samsung Galaxy S2,my problem comes when i make normal calls i still have to choose between Dialer or skype even if skype is not running?

Why is this ?

Surely you would only want to make skype calls when your skype application is running ?

when it is not running i dont see why i have to choose between skype or dialer?

can this be fixed with  an upgrade? if not i will uninstall this app cause it causes more fustration than joy !

Please help me i have never had this problem before with any of my other phones that i has skype installed on ,on my other phones i have to run the skype app to make skype calls ....this seems logical ...unlike what i am going through now.





Message 1 of 14 (13,231 Views)
13 Replies
Casual Adventurer

You get an option to choose the "default" dialer, at least I did!


Think from memory you may have to hit the home button when you have the choice of 2 on screen.

Message 2 of 14 (13,073 Views)
Casual Adventurer

I am planning to purchase a Samsung Galaxy Gio and would like to use Skype whenever possible. To install Skype, you need to access the Internet on the phone, right? Are there downloads to my PC available from Skype to transfer to the phone from the Android Market website or do they need to be directly accessed from the phone? This may be a simple question as my current cell phone is just a "phone" text, no Internet. It would be better if Skype would provide the initial set of instructions to using Skype on a mobile phone.

Message 3 of 14 (13,054 Views)
Novel Tourist

I have Skype installed on my Galaxy S2. When I made a call I was always offered an option of using dialler or Skype which worked fine. Foolishly the other day I selected dialler as the default option and I am now no longer offered Skype as an option when I make a call. How do I revert back please to being offered connection options when I make a call? I have searched the settings menus on my S2 and can't find a way! Thanks for any help.

Novel Tourist
I have the same problem. Also, is thetre a way to access your Contacts when using Skype? or do I have to enter them all again?
Message 5 of 14 (10,035 Views)
Novel Adventurer

I really liked being offered to dial with

Skype or Dialer.

I no longer have this option.

Can someone help me getting this option back?





Skype version:

Phone: Samsung Galaxy S2
model: GE-I9100
Android: 4.0.4
baseband version: I9100XXLQ6
kernel: 3.0.15-1056084

Message 6 of 14 (9,788 Views)
Novel Tourist

jmpaq In my case I also wanted to have both options (Skype and normal dialer). 

I tried many ways but I came to one final solution:

uninstall skype and re-install it.

This solved the problem.

Not sure this solution fits your needs, bu it did for me.

Message 7 of 14 (9,532 Views)
Novel Adventurer

I also uninstalled-reinstalled skype and it worked.

many thanks.


Message 8 of 14 (9,518 Views)
Novel Tourist

Please check if you can see All in Application Manager and select Phone and then Clear Defaults. It will help.




Roshin Alex

Skype: roshin.alex

Message 9 of 14 (8,817 Views)
Novel Tourist
What helped for me was:
1) Go to the Home screen;
2) Open up the main MENU (bottom left);
3) Navigate to Settings\Application Manager\All\Skype;
3) Click "Clear Defaults" for the option "Launch by default";
Message 10 of 14 (8,766 Views)
Discussion Stats
  • 13 replies
  • 7 kudos
  • 13 in conversation