By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

No video calling on Nexus 7

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist


I have a google nexus 7 with the latest versions of android (4.2.1) and skype ( but I can't get my video calling to work.

I've downloaded the camera launcher apps recommended in the skype community but none of these have changed anything. I get a black screen for a second when I try and start the video call but it reverts straight back to voice only calling. I can neither receive or send video.

I've uninstalled and reinstalled both the camera apps and skype and rebooted by tablet but it still won't work.

I can get voice calling to work and my camera is also working independently.

Please would you advise me on how to fix this?

Many thanks!

Message 1 of 7 (6,215 Views)
6 Replies
Casual Adventurer

I'm in the same boat. One of the reasons I bought the Nexus7 was that I travel a lot and thought, from the reviews, that talking to home and family would be a doddle on this Android device. I have yet to get it to work. Sound is OK, Video Not OK. Could someone from Skype say if there is a fix or is the primary problem with Google?


Anyone who actually has their Nexus7 & Skype Video working without problem would do us all a favour if they could say how they got it to work.

Message 2 of 7 (6,087 Views)
Casual Adventurer

Miracles do happen. Have done nothing new/changed no settings on my Nexus and tried to ring my family in Switzerland and strangely got a really good connection and good video picture - my d in l said it was better than my high tech home PC picture etc.  So, if it keeps on going like this, I shall be happy.  But very strange

Message 3 of 7 (6,061 Views)
Novel Tourist
Same problem here , please fix for us , its really important with me.
Message 4 of 7 (5,892 Views)
Casual Adventurer

I know how I felt before I got mine to work.  I havd no idea how I did it, but I will add a couple of things that may help.

1. When you open Skype on your Nexus7, there should be four icons in the top right of the screen: a video cam, a + sign, a phone and a vertical three dots.

2. In 'settings' from the Home screen of the Nexus, scroll down to Skype and see if there is anything there untoward. I simply have Contact with a tick beside it to enable cantacts to be 'synced'.

3. Do you have the Camcorder app installed as well as the camera? Mine is simply called 'Camcorder' version #1

4. I don't know if it has any bearing on the matter, but I also have Flash installed - without that, I could not play BBC iPlay or TV Catchup - which is even better than the BBC iPlayer.

I hope that at least one of the above may help. Please report back if it does, as that may help other people with the same problem.  Good luck!

Message 5 of 7 (5,882 Views)
Casual Adventurer

Just found the fix that worked for me.

Open Skype.

Click on your 'Profile'

Click on the three vertical dots at top right of screen.

From the drop down box click 'Settings'

tap Voice and video calls

Tap the box against Enable Video calling so that a tick appears in the box.


Message 6 of 7 (5,860 Views)
Novel Tourist

Hi Everyone

I suddenly had the same problem on my Nexus 7 4.3.No video Icon.I can see the otherside and hear.

I just cleared Skype cache and data in applicatios.Resigned into Skype.

Glad to say it is working.



Message 7 of 7 (3,961 Views)
Discussion Stats
  • 6 replies
  • 0 kudos
  • 4 in conversation