By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

I found why sound choppy problem occurs

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Experienced Adventurer

I'm found why sound choppy problem occurs.

Problem in proximity sensor! When I'm move my hand closer to proximity sensor, then display is off and sound choppy beginning. When I'm move my hand away, then display come on and sound choppy disappearing.

 

So problem in proximity sensor, this is a bug related to proximity sensor handling in the skype.

 

Please fix this bug and add setting option to allow disable proximity sensor usage from skype call.

Message 1 of 10 (5,892 Views)
9 Replies
Community Manager

Thanks for sharing your findings. Skype is aware of this limitation and will probably address it in a future update.


Found a helpful message? Give it a Kudo below to say "thanks" ¦ Latest Community News
Did my reply answer your question? Accept it as a solution to help others, Thanks.
Message 2 of 10 (5,876 Views)
Novel Adventurer
Hi noticed the same problem with my HTC Wildfire S. Is there any way to go back to the previous version of Skype? I think it was the 1.0.0.983. That was worked perfectly on my device...
Message 3 of 10 (5,838 Views)
Experienced Adventurer

yes, previous version works with proximity sensor more better, in 983 you can talk for about 2 minutes before sound choppy appears, and you can talk very long time when use headset or speaker to avoid contact proximity sensor...

 

I'm install 983 back from APK file, because old version give chance to answer without use headset. New version 2.0.0.45 start sound choppy immediately after contact to proximity sensor...

Message 4 of 10 (5,831 Views)
Experienced Adventurer

New version 2.0.0.47 appears in the market, but skype bug with proximity sensor is still not fixed. Also I found that when you enable speaker, then skype dont use proximity sensor and sound choppy also dont appears. New version have the same problem - when you touch proximity sensor during the call, skype stops work normaly and begin sound choppy. When you dont touch proximity sensor (to avoid display off), then skype works good.

 

So I'm come back on 983 again and waiting for fix of this issue (skype bug with proximity sensor)

Message 5 of 10 (5,825 Views)
Casual Adventurer

THAT IS SAME PROBLEM ON MY htc magic plz fix it

Message 6 of 10 (5,653 Views)
Casual Adventurer

is there any version that works good?

Message 7 of 10 (5,649 Views)
Experienced Adventurer

I think you will find that when the proximity sensor cuts in the processor runs slower,as it acts as a battery saver.Therefore there is not enough cpu speed to run Skype,which requires about 600mhz.

Maybe the only way round it is to put the phone onto loudspeaker & turn the volume down to 30% & use that as your earpiece,that's what i do anyway.

IF MY POST HAS HELPED YOU,PLEASE CLICK MY KUDOS,THANKS.
Message 8 of 10 (5,642 Views)
Experienced Adventurer

If you have a Wildfire,or a phone which does not support video calling,why not downgrade to an earlier version of Skype.Uninstall v 2.xxx & go into google on your phone & find freewarelovers.com /android / apps/skype old_ versions [sorry cant post complete link,not allowed here] scroll down the page & you will find most old versions,tryv983  or 984,i've found this to work a bit better than the latest v2xxx update.You can click on the link of the version you want there & download it direct in minutes.

IF MY POST HAS HELPED YOU,PLEASE CLICK MY KUDOS,THANKS.
Message 9 of 10 (5,635 Views)
Casual Adventurer

Hello, I actually WANT to use skype with screen off, for audio, in order to save screen/power, but the lag does start when that happens.  what to do?

Message 10 of 10 (5,250 Views)
Discussion Stats
  • 9 replies
  • 5893 views
  • 6 kudos
  • 6 in conversation