By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Android Unknown Contacts

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

I'm using Skype on my Samsung Galaxy S 2 (the new version of Skype - with video) and when I signed in and set it to synch contacts, it filled my Android contact list with tons of "unknown contacts" that I can't delete.

I only have a few contacts in my actual skype account and I cant seem to see where they have come from and how I can get rid of them.

 

Any ideas?

Message 1 of 24 (5,671 Views)
23 Replies
Community Manager
Open Skype and from within the settings you can disable showing your Skype contacts in your phone's address book.

Found a helpful message? Give it a Kudo below to say "thanks" ¦ Latest Community News
Did my reply answer your question? Accept it as a solution to help others, Thanks.
Message 2 of 24 (5,492 Views)
Novel Adventurer

Nope, it does not work. Same phone, same Skype version, but the 8137 Unknow contacts added by skype are still there even after reboot. My setting were "sych only existing contacts" and now are "do not synch". Please help me remove these contacts that pollute my phone.

 

Message 3 of 24 (5,459 Views)
Novel Adventurer
The solution is to uninstall skype, and then reinstall without synchronizing contacts.
Message 4 of 24 (5,458 Views)
Novel Tourist

This is not a solution - to turn off the synchronisation. I would like to have skype contacts in phone contacts to speed up calling with skype.

Skype, please fix this annoying bug!!

 

Message 5 of 24 (5,404 Views)
MP
Novel Adventurer
Yes I have the same problem. It's horrible. I have only a handful of Skype contacts but getting my contacts filled with thousands of unknown uneditable skype contacts that "don't exist"!!
Hope someone at Skype/Samsung is taking notice and can fix this.
Message 6 of 24 (5,399 Views)
Novel Tourist

I don't know if it works, but worths a shot:

Try synchronization Contacts only from the phonebook:

sync with existing contacts

 

Message 7 of 24 (5,362 Views)

It would nice if you could state that this is a regonised defect, otherwise, a lot of people that see this post will think that there still might be work-around for this issue, excepting turning off the sync facility.

Message 8 of 24 (5,317 Views)
Novel Tourist

I've done exctly that on my HTC Sensation and the Unnamed contacts don't show in the contact list anymore, but they still exist on the phone as they show up in other applications.

 

For example, I have this BooksApp that includes linked to contacts and that contact list starts with many hundreds of Unnamed contacts and continue with many dussins of duplicate contacts of a couple of phone numbers I've called with Skype, since installing it a couple of weeks ago.

 

Also, HTC Sense's smart contact linking feature has now started to suggest that the duplicate Unnamed contacts and phone number contacts should be linked and I get link suggestions every now and then.

 

There are no Unnamed contacts or contacts with just a phone number in my Skype account, so this should all be related to Skype's otherwise great Android application.

 

It would be nice to know when/if there is a permanent solution to this issue.

Message 9 of 24 (5,302 Views)
Casual Tourist

Would a Skype Moderator PLEASE step in and research this bug? I have had to uninstall skype... and would switch to Google Talk just so this stops happening... It strains my Phone... all the replies above only address the symptoms (turn off sync, Reboot and never sync)... Ideally using skype contacts would be seamless between your Phone and Desktop versions of Skype...

Message 10 of 24 (5,286 Views)
Discussion Stats