Re: Poor video quality on Skype for Xbox One

Welcome to the Skype community. To get started please read our short welcome post. Thanks!
Reply

Re: Poor video quality on Skype for Xbox One

Do any of you notice (or the recipeints notice) that the call starts out fine and then after a few seconds it tries to "lock in" (for lack of a better term) and that's when it gets all pixelated and awful?

 

Every one of my calls to all 3-4 of my regular contacts starts out fine and then there seems to be this very slight hiccup and then it becomes severely degraded.  

 

Skype support has been an absolute, unacceptable joke.  They have repeatedly bounced me over to Microsoft support.  MS support is just as bad.  I was IM'ing with Skype support and the rep told me he had heard of the issue and would be emailing me a list of troubleshooting steps that would more than likely resolve the issue.  Well - about 2 hours after our chat session I got an email from him advising me to contact MS support with a link.  Unbelievable.

 

If I do not get some sort of REAL assistance soon I will be certain to post many YouTube clips and reviews anywhere I can exposing this issue and providing a substantial warning to those thinking of purchasing an Xbox One.  

 

The fact that no one from Skype can actually set up a test call with me to see the issue first hand is bizarre.  And that fake email address they provided in this thread to which I have had zero response is a joke as well.  

 

Very frustrated that we cannot get some sort of real assistance.

0 Kudos
Spooky73
Novel Adventurer
Kudos: 1
Posts: 4
Registered: 06-12-2013
Message 41 of 68 (1,205 Views)

Re: Poor video quality on Skype for Xbox One

[Removed for privacy] skype
0 Kudos
fortsas261
Reliable Voyager
Kudos: 0
Posts: 1
Registered: 04-10-2011
Message 42 of 68 (1,168 Views)

Re: Poor video quality on Skype for Xbox One

Sorry to hear you haven't received feedback, I'm having a very similar problem on my Xbox One.  Hopefully they'll have a solution for you which will probably help myself and many others out.

Posted from Microsoft Windows RT Tablet
0 Kudos
tevery
Novel Adventurer
Kudos: 1
Posts: 2
Registered: 04-01-2014
Message 43 of 68 (1,131 Views)

Re: Poor video quality on Skype for Xbox One

I read ACSCREATIVES's post from Tuesday indicating that when the Sonicwall firewall was taken out of the system, that the video call clarity between Xbox Ones became perfect.  So, that got me thinking about my system.

 

I am not running a dedicated firewall, but am running a pfSense router in the system that has some complex routing settings and a built in firewall.  The short story is that when I take this router completely out of the system, I get crystal clear Skype video calls between the Xbox Ones that previously had very poor pixelated video calls.  When I put that router back in the system, the calls are very poor and pixelated again.

 

So it must be the pfSense router that isn't playing nice with the Xbox One Skype application.  However, this is a bit strange given all the other crystal clear Skype troubleshooting video calls from and to other non-Xbox One devices that were made with the pfSense router in the system that I indicated in my previous post here:

 

http://community.skype.com/t5/Xbox-One/Poor-video-quality-on-Skype-for-Xbox-One/m-p/2491121#M316

 

Does anyone have any suggestions on what the settings need to be in the pfSense router for it to not interfere with the Xbox One Skype video calls?  I provide more information on my set-up below if helps anyone think of what might be the issue.  I have not made any firewall settings in the pfSense router, so it is now basically running just as it would with a fresh install.

 

So, my set-up is quite complicated given the description in my previous post.  In addition to those details, my main home router is a Linksysy E4200 that serves all the addresses to the home network.  However, before that router connects to the cable router I have two more routers in between.  By the way, as I indicate above, all of the other complications in this network set-up allow the Xbox One video call quality to be crystal clear when I take the pfSense router out of the system.  So the issue is definitely something interacting between the Xbox One and the pfSense router.  The network set-up looks like this:

 

Cable ->

Motorola Surfboard SB6120 (cable modem) ->

Linksys E4200 ->

pfSense Router (Thinkpad T410 running pfSense 2.1-RC1) ->

Linksys E4200 (home network) ->

All devices including the Xbox One

 

I can now make crystal clear Xbox One video calls with the pfSense router taken out of the system, but I want to keep the pfSense router in the system since it servers a specific purpose for me.  Any advice on how to tweak the pfSense router to play nice with the Xbox One video calls would be appreciated.

 

Thanks,

 

0 Kudos
Skyper_123
Novel Adventurer
Kudos: 5
Posts: 3
Registered: 25-12-2013
Message 44 of 68 (1,098 Views)

Re: Poor video quality on Skype for Xbox One

More info for everyone.  I solved the problem I was having with poor Skype video call picture quality between two Xbox Ones. 

 

From my last post I had determined that the issue had been narrowed down to the way one of my routers (pfSense) was interacting with the Xbox One, because moving the Xbox One in front of it resulted in excellent Skype video call quality.  Now I have determined what router settings were causing the issue, and will share this below so it can hopefully some other people.  I realize this might not work for everyone, but it solved the problem for me.

 

The source of the problem I was having was basically a NAT, UPnP & Port Forwarding configuration issue.  To make a long story short, what needs to happen is that the Xbox One needs to confirm that it has an “Open” type NAT to be sure that the video call quality can be excellent (assuming everything else is up to par).  Apparently a less than Open NAT on the Xbox One also results in some restrictions in other chat functions, loss of ability to connect to some other players in games, inability to host games, and who knows what else.  Getting an Open type NAT is not easy for a lot of people as there are posts all over the internet on the topic.  In those posts, there is a lot of conflicting stories on how people were able (or not able) to get an Open NAT type.  Here is what I did to get this Open type NAT, and as a result get excellent Skype video call picture clarity between Xbox Ones.  Note that I did a lot of tests, and every time I had poor video quality I also had a NAT type that was less than Open, and every time I had an Open type NAT I had excellent video quality.

 

First thing to check is what NAT type your Xbox One has now.  You do this in [Settings]->[Network].  In the center of the screen it will say Current Network Status, the type of connection [wired or wireless], and NAT Type: [Open <or> Moderate <or> Strict].   Anything less than Open for me results in a pixelated Skype picture between Xbox Ones.

 

To get an Open NAT type the router that is serving the addresses to your Xbox One has to have UPnP enabled.  With a simple one router set up such as:

 

Cable ->

Motorola Surfboard SB6120 (cable modem) ->

Linksys E4200 (Tomato Toastman)->

Xbox One

 

I am able to get an Open NAT by only ensuring UPnP is enabled (no port forwarding or anything else required).  I did have to make sure the settings were made and saved in the router, turn off the Xbox One (hard off in [Settings]->[Power & startup]->Power mode = “Energy-saving”, and not standby by Power mode = “Instant-on”), restart the router, then turn the Xbox One back on.  But it did work.  If it doesn’t for you, then I suggest you keep searching to try to find out how to get an Open type NAT, as that seems to be the key to happiness.  By the way this worked regardless if I hooked the Xbox One to the router wirelessly or with an Ethernet cable.

 

However my network is much more complicated:

 

  1. Cable ->

  2. Motorola Surfboard SB6120 (cable modem) ->

  3. Linksys E4200 (Tomato Toastman)->

  4. pfSense Router (Thinkpad T410 running pfSense 2.1-RC1) ->

  5. Linksys E4200 (Tomato Toastman [home network]) ->

    -Some of my network devices [wired and wireless 2.4Ghz]

  6. Linksys E4200 (Tomato Toastman, wireless bridged on 5Ghz, )->

    -Other devices on same network (including Xbox One} [wired and wireless 2.4Ghz]

 

So I had to do a lot more steps as follows:

 

The pfSense router has a built in firewall, and it turns out that it has a setting that creates something called “Symmetrical Ports” by default.  This apparently makes a connection to a remote IP & port but changes the port that the internal and external device uses at the firewall.  So the result is that a single port isn’t used across the connection.  With this setting enabled, you will never get anything other than a “Strict” type NAT.  You can read more about this here if interested:

 

http://think-like-a-computer.com/2011/09/19/symmetric-nat/

 

So, this had to be changed.  Here is an explanation from pfSense, and a video from someone else explaining how to stop Symmetric Ports in pfSense:

 

https://doc.pfsense.org/index.php/Static_Port

https://www.youtube.com/watch?v=28dmUzOGI50

 

So as I mentioned above if this happens to be the router that the Xbox One is attached to directly, then the UPnP also needs to be turned on in pfSense.  Here is an article explaining how to enable UPnP in pfSense:

 

http://pfsensesetup.com/pfsense-upnp-and-nat-pmp/

 

However, if this is only an in-between router as in my configuration, the UPnP doesn’t need to be enabled on the pfSense router (4), or as a matter of fact, on the 1st E4200 router (3) in my network either.

 

My Xbox one is effectively behind the 2nd E4200 (5) in my network even tough there is another router in between (6).  The 3rd E4200 (6) is ignored from a networking perspective because it is only acting as a wireless bridge in the network, and its “routing” functions are turned off.

 

This means that the UPnP setting needs to enabled on this 2nd E4200 (5), and not on any routers prior (at least to achieve an Open NAT on the Xbox One.  There may be a lot of reasons to have UPnP turned on for those other routers as well, but it is not necessary for this specific purpose…).

 

Now, one might think that this would do the trick, but it turns out that by stacking a bunch of routers together results in some more work.  UPnP doesn’t work so well behind my other routers.  So to fix this problem, I had to port forward all of the relevant Xbox One ports from the 1st E4200 Router (3) to the pfSense router (4), then from the pfSense router (4) to the 2nd E4200 router (5).  Note that I didn’t have to forward the ports from my 2nd E4200 router (5) to the specific IP address of the Xbox One.  So you are probably asking yourself what the pertinent ports are that need to be forwarded for Xbox Live.  They can be found here:

 

https://support.xbox.com/en-US/xbox-one/networking/network-ports-used-xbox-live

 

Copied here for reference:

•Port 88 (UDP)

•Port 3074 (UDP and TCP)

•Port 53 (UDP and TCP)

•Port 80 (TCP)

•Port 500 (UDP)

•UDP Port 3544 (UDP)

•UDP Port 4500 (UDP)

 

Also if you want to get an Open type NAT in the specific game Call of Duty Ghosts, then also forward this port as well (this will not affect whether the Xbox One itself get an Open type NAT, just the game):

 

•UDP Port 3075 (UDP and TCP)

 

Of course forwarding ports can be confusing, so here are some instructions on how to do it (at least for a tomato, and pfSense router):

 

https://www.youtube.com/watch?v=Imkbsh9Ct5I

http://pfsensesetup.com/port-forwarding-with-nat-in-pfsense/

http://hubpages.com/hub/Port-Forwarding-in-pfSense-How-to-Configure-NAT

http://www.wi-fiplanet.com/tutorials/article.php/3829536/How-to-Set-Up-Port-Forwarding-with-Tomato.h...

 

You may be asking yourself what the destination IP address of the port being forwarded should be if the Xbox One isn’t in this portion of the network and can’t therefore be the destination IP address.  Well it is the IP address of the next router in the network where you forward the ports to.  So for example, if the first router gets its WAN address from the cable modem, and it is given the external public IP address, the next router in the network will receive an IP address from the LAN side of the first router.  This LAN address given by the first router becomes the WAN address of the next router in the network.  So if the first router has a LAN address range of 192.168.1.2 – 192.168.1.245, then the 2nd router in the network will get one of the IP addresses in that range.  So the WAN address of the second router will be 192.168.1.XXX with the XXX being assigned by the 1st router.   Therefore, the ports are forwarded to the LAN address of the next router in the network which is 192.168.1.XXX.  One thing to note is that if the XXX in the IP address is dynamic, and assigned each time the routers start, the port forwarding rules will have to be changed each time the router reassigns the IP address to the 2nd router.  To avoid this, set the second router with a Static DHCP assigned to the 2nd routers MAC address.  Then the second router will always receive the same LAN address, and therefore the forwarding rules don’t need to be changed again.  Then keep following this pattern from the 2nd to the 3rd router and so on if you need to.  Here is a page explaining how to set up Static DHCP in DD-WRT:

 

http://www.howtogeek.com/69612/how-to-set-up-static-dhcp-on-your-dd-wrt-router/

 

I then effectively have these router settings:

 

1st E4200 router (3) Port Forward Xbox Live Ports to pfSense router (4)

pfSense router (4) Port Forward Xbox Live Ports to 2nd E4200 router (5)

pfSense router turn OFF Symmetric Ports

2nd E4200 router (5) turn ON UPnP

 

After making all these settings and saving, turn off the Xbox One, and all routers.  Then restart the devices in this order waiting for the first one to finish booting up before turning on the second:

 

1st E4200 router (3)

Pfsense rotuer (4)

2nd E4200 router (5)

Xbox One

 

Doing this always results in an Open NAT for me, and then excellent Skype video call picture quality between Xbox Ones.  Just to note what results in different NAT types and therefore pixelated Skype video calls between Xbox Ones with my set-up: 

 

Turn OFF Port forwarding in 1st E4200 (3) or pfSense Router (4):       NAT Type = Moderate

Turn OFF UPnP on 2nd E4200 router (5):                                                  NAT Type = Moderate

Turn ON Symmetric Ports in pfSense router (4):                                     NAT Type = Strict

 

If I move the Xbox One directly behind the 1st E4200 router (3) instead of its normal position, this what happens:

 

Turn ON UPnP and turn OFF port forwarding on 1st E4200 router (3):     NAT Type = Open

Turn OFF UPnP and turn OFF port forwarding on 1st E4200 router (3):    NAT Type = Moderate

 

Good Luck!!

Skyper_123
Novel Adventurer
Kudos: 5
Posts: 3
Registered: 25-12-2013
Message 45 of 68 (1,071 Views)

Re: Poor video quality on Skype for Xbox One

Some of us are having problems with only our xbox one and skype.  all my other devices have awesome outgoing video quality. It is only my xbox one with the problem.  I still have the quality problem with my xbox one connected directly to my modem with no firewalls. microsoft refuses to answer our emails or even post in this topic.

Posted from Microsoft Windows RT Tablet
0 Kudos
majortom1981
Routine Adventurer
Kudos: 1
Posts: 16
Registered: 20-12-2013
Message 46 of 68 (997 Views)

Re: Poor video quality on Skype for Xbox One

[ Edited ]

In case there is some odd negotiation compatibility wired causing sporadic performance issues I would suggest disabling NIC Auto negotiation and see if performance changes when set to static values. i.e. 10/100/1000  Full/Half Duplex.  Hopefully these options exist on the Xbox One.  Auto doesn't always work well from hardware vendor to vendor (inability to maintain negotiated speed between hardware so packets are intermittently lost or halted). Wireless also has differing issues regardless of both Wired and Wireless having set standards.

0 Kudos
techfreak
Community Ambassador
Community Ambassador icon
Kudos: 1125
Posts: 4285
Registered: 30-11-2012
Message 47 of 68 (986 Views)

Re: Poor video quality on Skype for Xbox One

that is not it because the xbox speed on the console showsa the correct 60/25 speeds. I can also play hdx files on vudu on the console with no problems.

0 Kudos
majortom1981
Routine Adventurer
Kudos: 1
Posts: 16
Registered: 20-12-2013
Message 48 of 68 (977 Views)

Re: Poor video quality on Skype for Xbox One

The link in question would be between your modem and the Xbox One.  It's my understanding the Xbox 360's Ethernet port wasn't Gigabit capable, it's possible the Xbox One brings with it more compatibility issues.  Being able to pass a speed test doesn't really discount the problem as you don't really directly connect to your ISP's high end with fiber at 100/1000 that's handled by the modem/converter.  Having stable hdx file transfers may be  a more convincing argument that you are not running into this issue.  However If I was having problems I wouldn't discount any troubleshooting I had available to me.  In any case what might not work for you, may work for others.

0 Kudos
techfreak
Community Ambassador
Community Ambassador icon
Kudos: 1125
Posts: 4285
Registered: 30-11-2012
Message 49 of 68 (974 Views)

Re: Poor video quality on Skype for Xbox One

it is not a mismatch its a bug in how skype determines what quality to set the video. all other high end streaming works on my console. it is only skype that does not work. changing the speed manually will not work because i do not have access to set the cable modem to manual.

0 Kudos
majortom1981
Routine Adventurer
Kudos: 1
Posts: 16
Registered: 20-12-2013
Message 50 of 68 (966 Views)
Reply

© 2014 Skype and/or Microsoft. The Skype name, associated trade marks and logos and the "S" logo are trade marks of Skype or related entities. Use of this website constitutes acceptance of the Terms of Use and Privacy and Cookie policy.

No emergency calls with Skype
Skype is not a replacement for your telephone and can't be used for emergency calling