Skype audio splits to both headphones and speakers...

Welcome to the Skype community. To get started please read our short welcome post. Thanks!
Showing results for 
Search instead for 
Do you mean 
Reply
Accepted Solution

Skype audio splits to both headphones and speakers when using headphones -- how to prevent?

What I am using:

HP ProBook 4430s

Windows 7 Home Premium

Skype 6.1.0.129

 

What I know of the problem:

1. During Skype calls, all audios from the call go through headphones while all other audio (i.e. youtube, iTunes, etc.) go through the internal laptop speakers.

 

2. Previously, I could listen to both through solely headphones.

 

3. When I am not in a Skype call, the audio works just fine and streams through the headphones when they are plugged in.

 

4. When I enter in a Skype call and click on the Volume Mixer, volume control options appear for both headphones and the laptop speakers.

 

5. Prior to this problem, only one volume control option appeared.

 

6. Skype forces me to use either the laptop speakers or my headphones to hear audio from a call.

  a. If I select to use headphones as the speakers in the audio settings and unplug them, the audio from the call will not stream from the laptop speakers.

     i. Prior to the problem, if I unplugged my headphones, Skype would automatically adjust to stream the call audio from the laptop speakers instead.

 

7. I can force all audio to play through my headphones by disabling my laptop speakers; however, this is only a workaround and not a solution.  If I wanted to use my laptop speakers, I would have to go through the tedious task of re-enabling it every time.

 

8. As far as I know, this problem exists only in Skype and does not affect Google Hangout.

 

My current Skype audio settings are as follows:

Microphone - Integrated Microphone Array (IDT High Audio Definition CODEC)

Speakers - Communications Headphones (IDT High Audio Definition CODEC)

Ringing - Use Selected Speakers

 

Question/What I would like fixed:

Is there a way to stream the audio from only one source?  Skype calls seem to be forcing two different audio devices to stream.  Thanks in advance!

nyxacith
Casual Adventurer

images.message_type_solution.altAccepted Solution

Tried it reverting to an older version of Skype.  Didn't work.

 

But!  I believe I may have found the solution.

 

Here are the steps I took to solve the issue:

 

1. Right click on the audio volume control icon -> Playback devices.  The Sound window and Playback tab should be open.

2. Set Speakers/HP as both the Default Device and the Default Communications Device.

3. Go to Skype>Tools>Audio Settings.  Set Speakers settings to: Speakers/HP (IDT High Audio Definition CODEC).

 

Hopefully this will work for anyone else who has the same or a similar problem.

View solution in original post
nyxacith
Casual Adventurer
Kudos: 80
Posts: 5
Registered: 25-01-2013
Message 1 of 53 (93,773 Views)

Re: Skype audio splits to both headphones and speakers when using headphones -- how to prevent?

ruwim
Community Ambassador
Community Ambassador icon
Kudos: 6279
Posts: 42289
Registered: 27-06-2011
Message 2 of 53 (93,734 Views)

Re: Skype audio splits to both headphones and speakers when using headphones -- how to prevent?

Thanks for the reply.

 

Okay, so I followed the instructions of the other post.  Right-clicked on the volume control icon to the time and opened up Playback devices.  Speakers/HP is already enabled as the default device.  I tried opening Skype again and testing it to make sure, but during a call, sounds will still stream from the laptop speakers when my headphones plugged in.

 

playback devices.png

 

Any other ideas?

nyxacith
Casual Adventurer
Kudos: 80
Posts: 5
Registered: 25-01-2013
Message 3 of 53 (93,725 Views)

Re: Skype audio splits to both headphones and speakers when using headphones -- how to prevent?

You can revert to older version of Skype 6.0

http://download.skype.com/msi/SkypeSetup_6.0.0.126.msi

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Tamim
Super Aviator
Kudos: 6204
Posts: 32360
Registered: 27-09-2011
Message 4 of 53 (93,713 Views)

Re: Skype audio splits to both headphones and speakers when using headphones -- how to prevent?

Tried it reverting to an older version of Skype.  Didn't work.

 

But!  I believe I may have found the solution.

 

Here are the steps I took to solve the issue:

 

1. Right click on the audio volume control icon -> Playback devices.  The Sound window and Playback tab should be open.

2. Set Speakers/HP as both the Default Device and the Default Communications Device.

3. Go to Skype>Tools>Audio Settings.  Set Speakers settings to: Speakers/HP (IDT High Audio Definition CODEC).

 

Hopefully this will work for anyone else who has the same or a similar problem.

nyxacith
Casual Adventurer
Kudos: 80
Posts: 5
Registered: 25-01-2013
Message 5 of 53 (93,710 Views)

Re: Skype audio splits to both headphones and speakers when using headphones -- how to prevent?

It seems like the problem is between the old and newest Skype version. Some people got the update automatically and some did not get the update and then when tried to make a call between two different versions, the audio cuts out.
So it seems like either the other has to uninstall the newest version and revert it to Skype 6.0 or the other has to update his Skype into the newest version:
Here is a link for the newest update:
http://community.skype.com/t5/Windows-desktop-client/Skype-Problems-Troubleshooting/td-p/52260

Hope this helped someone
BETAOPTICS
Casual Tourist
Kudos: 1
Posts: 1
Registered: 27-01-2013
Message 6 of 53 (93,274 Views)

Re: Skype audio splits to both headphones and speakers when using headphones -- how to prevent?

This works for me...thanks a lot... :happy:
mlsumulong
Casual Tourist
Kudos: 0
Posts: 1
Registered: 27-01-2013
Message 7 of 53 (93,210 Views)

Re: Skype audio splits to both headphones and speakers when using headphones -- how to prevent?

Worked beautifully! Thank you very much!! :happy:


nyxacith wrote:

Tried it reverting to an older version of Skype.  Didn't work.

 

But!  I believe I may have found the solution.

 

Here are the steps I took to solve the issue:

 

1. Right click on the audio volume control icon -> Playback devices.  The Sound window and Playback tab should be open.

2. Set Speakers/HP as both the Default Device and the Default Communications Device.

3. Go to Skype>Tools>Audio Settings.  Set Speakers settings to: Speakers/HP (IDT High Audio Definition CODEC).

 

Hopefully this will work for anyone else who has the same or a similar problem.


 

zelima89
Casual Tourist
Kudos: 8
Posts: 1
Registered: 29-01-2013
Message 8 of 53 (92,929 Views)

Re: Skype audio splits to both headphones and speakers when using headphones -- how to prevent?

[ Edited ]

.

artsigirl144
Novel Adventurer
Kudos: 2
Posts: 4
Registered: 30-01-2013
Message 9 of 53 (92,675 Views)

Re: Skype audio splits to both headphones and speakers when using headphones -- how to prevent?

okay so this solution works for a bit. but now when i play sounds say from youtube, the video audio from the skype call gets sent to my laptop speakers and the youtube video audio stays in my earphones. what do i do? i'd like all audio to say in my earphones
artsigirl144
Novel Adventurer
Kudos: 2
Posts: 4
Registered: 30-01-2013
Message 10 of 53 (92,669 Views)
Reply

© 2014 Skype and/or Microsoft. The Skype name, associated trade marks and logos and the "S" logo are trade marks of Skype or related entities. Use of this website constitutes acceptance of the Terms of Use and Privacy and Cookie policy.

No emergency calls with Skype
Skype is not a replacement for your telephone and can't be used for emergency calling