Cannot close/terminate Skype in Windows 8

Welcome to the Skype community. To get started please read our short welcome post. Thanks!
Reply

Cannot close/terminate Skype in Windows 8

Hi,

 

I had installed Skype (desktop version) on Win8.

When it starts it sometimes works weird - cannot login or cannot send chat message to online user.

But the most annoying issue is that I cannot close this program and cannot even terminate it with Task Manager or ex. Process Hacker.

When I try to terminate it again (second and subsequent attempts), Task Manager claims that access to the process is denied.

Process Hacker allows to see treads and stack of those threads. 

At this moment Skype has only one thread and it seems hang forever on closing the socket:

0, ntdll.dll!NtClose+0xa
1, wow64.dll!Wow64EmulateAtlThunk+0x2639
2, wow64.dll!Wow64SystemServiceEx+0xd7
3, wow64cpu.dll!TurboDispatchJumpAddressEnd+0xb
4, wow64.dll!Wow64SystemServiceEx+0x26a
5, wow64.dll!Wow64LdrpInitialize+0x435
6, ntdll.dll!RtlWow64CallFunction64+0x3b
7, ntdll.dll!LdrInitializeThunk+0xe
8, ntdll.dll!ZwClose+0xc
9, mswsock.dll!Tcpip6_WSHGetSockaddrType+0x840
10, ws2_32.dll!closesocket+0xd5
11, Skype.exe+0x30021e
12, Skype.exe+0x2f95ae

 

Is there any way to fix this problem?

 

Dmitry

divis1969
Novel Tourist
Kudos: 0
Posts: 1
Registered: 26-02-2013
Message 1 of 3 (940 Views)

Re: Cannot close/terminate Skype in Windows 8

See this similar case:

 

http://community.skype.com/t5/Windows-8-from-Windows-Store/Skype-crash-on-windows-8-RTM/m-p/1153010#...

 

Disabling Internet Connection Sharing service may help.

ruwim
Community Ambassador
Community Ambassador icon
Kudos: 7346
Posts: 36620
Registered: 27-06-2011
Message 2 of 3 (935 Views)

Re: Cannot close/terminate Skype in Windows 8

Try Below:

 

Start your Windows in "Safe mode with networking".

Press WinKey + R to open the Run window

WinKey (the button is located between the left Ctrl and Alt with the Windows logo)

 

winkey1.png

 

type: msconfig.exe and press Enter

 

Boot >> Mark safe boot >> Mark Network

 

safemode.PNG


Restart your computer.

 

Please Do a Skype Reset.

 

Exit Skype : From the system tray >> right click on the skype icon and click "Quit"

 

esci da skype.PNG

 

Press WinKey + R to open the Run window

 

type: %programdata%\Skype\Apps and press Enter

 

programdata.PNG

 

Rename the folder login to login1.

 

again Press WinKey + R to open the Run window

 

type: %appdata% and press Enter

 

appdatait.PNG

 

Now try renaming folder "Skype" to "Old_Skype"

 

Download, unzip and run SafeMSI
http://www.windowsitpro.com/content/content/83387/SafeMSI.zip

 

Run Skype and Check connection settings

 

In Skype Click Tools >> Click Connection options...

 

type any port between 1024 and 65535

 

check this settings "use port 80 and 443.....incoming connections"

 

... if it had been ticked, then... Remove that check

 

disable uPnP.

 

SkypeProxy1.PNG

 

Also Unmark / uncheck 'Start skype when I start Windows'.

 

sswisw.PNG

 

Restart your computer to Normal Mode. (Run msconfig and untick Safe mode)

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Tamim
Super Aviator
Kudos: 8166
Posts: 32360
Registered: 27-09-2011
Message 3 of 3 (929 Views)
Reply

© 2014 Skype and/or Microsoft. The Skype name, associated trade marks and logos and the "S" logo are trade marks of Skype or related entities. Use of this website constitutes acceptance of the Terms of Use and Privacy and Cookie policy.

No emergency calls with Skype
Skype is not a replacement for your telephone and can't be used for emergency calling