missing "Enable uPnP" checkbox

Welcome to the Skype community. To get started please read our short welcome post. Thanks!
Showing results for 
Search instead for 
Do you mean 
This topic has been archived.
To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Reply

missing "Enable uPnP" checkbox

Hello all,

in my company, we are currently using Skype version 4.2.32.169, but some colleagues of mine are completely missing the "Tools / Options / Advanced / Connection / Enable uPnP" checkbox. Only the checkbox is not present, the rest of "Connection" is fine!

We already tried reinstalling and using a different version, but without success; anyway, version 4.2.32.169 is the standard client for this company.

 

Does anyone know if it's possible to get back the "Enable uPnP" checkbox, or why is it gone?

 

 

Thanks

Please use plain text.
LordRNK
Casual Adventurer
Kudos: 0
Posts: 5
Registered: 15-02-2012
Message 1 of 12 (4,612 Views)

Re: missing "Enable uPnP" checkbox

[ Edited ]

it sounds to me like there may be problem in shared.xml of those systems affected by this issue, since that is where the setting that controls whether Skype uses UPnP or not is stored

the easiest way to tell would be to Quit Skype on one of the systems affected, locate and rename the existing shared.xml, restart Sype and sign in (which will cause Skype to RE-CREATE a brand new shared.xml), and then check to see if the setting appears in Options

note that some OTHER non-default settings in shared.xml may need to be reset as per your preference if you end up deciding to use the new shared.xml

the easiest way to locate shared.xml is to hold down the Windows key on the keyboard, and then press r to open the Run dialog -- then type in %appdata%/Skype and click OK -- shared.xml should be immediately visible in Windows Explorer

you can search for "UPnP" in both the new and old copies on shared.xml if you wish to compare the settings in more detail

it is also possible that you may wish to repair the old/renamed shared.xml by manually editing the setting rather than going with the new shared.xml file (just make sure Skype is not running while editing and/or renaming shared.xml) -- however, I would recommend going with the new shared.xml file, since there is also the possibility that other corruption may exist in the old file

when Skype's use of UPnP is ENABLED, the entry should read:

<DisableUPnP>0</DisableUPnP>

hope this helps

Regards,
Neil
Please use plain text.
Neil
Super Adventurer
Kudos: 273
Posts: 4827
Registered: 27-06-2011
Message 2 of 12 (4,487 Views)

Re: missing "Enable uPnP" checkbox

Hi Neil,

I tried your suggestion, but it did not work on my colleague's PC: I renamed the shared.xml in shared.xml.backup and started Skype. It created a brand new shared.xml file, but it still won't connect and if I go under Options, I still can't see the "Enable uPnP" checkbox.

 

Please also note that on MY PC (where Skype is working fine, and I can normally see the checkbox), there is no mention of uPnP in my shared.xml file, and the entry <DisableUPnP>0</DisableUPnP> is not present as well; anyway, I have the checkbox and I connect fine.

 

Any suggestion?

 

 

Thanks

Please use plain text.
LordRNK
Casual Adventurer
Kudos: 0
Posts: 5
Registered: 15-02-2012
Message 3 of 12 (4,480 Views)

Re: missing "Enable uPnP" checkbox

[ Edited ]

quite often you won't find such entries in .xml files if the default has not been changed, and, in this case, UPnP is enabled by default -- that could explain why you don't see it in your shared.xml . . . yet

if you were to now turn UPnP OFF in Options (temporarily, of course), then I suspect you will see the entry in your shared.xml

I routinely turn UPnP OFF, and I am definitely seeing the entry in my shared.xml

but that still doesn't explain why your colleague doesn't see the tickbox in Options

What version(s) of Windows are we talking about here, both yours and the problem machine?

 

Also, does your colleague connect to a different router than you do, in particular a different make/model?

Regards,
Neil
Please use plain text.
Neil
Super Adventurer
Kudos: 273
Posts: 4827
Registered: 27-06-2011
Message 4 of 12 (4,473 Views)

Re: missing "Enable uPnP" checkbox

Hello Neil,

both mine and the problem machine's OS are:

 

Windows XP Professional, version 5.1 (2600), SP3

 

We are on the same network, so we are connected to the same network switch...

 

Anyway, I tried turning uPnP off and then on again, and now I can see the line in server.xml like you said.

Please use plain text.
LordRNK
Casual Adventurer
Kudos: 0
Posts: 5
Registered: 15-02-2012
Message 5 of 12 (4,464 Views)

Re: missing "Enable uPnP" checkbox

your case may be different, but there can be many routers involved in a corporate LAN, so it would be best to check if you are not absolutely sure

are both PC's wire-connected or wireless?

since you didn't mention what other version was tried, is there any chance you could try a more current version, like 5.5 or 5.6 at a minimum?

can you describe the problem machine in more detail, including whether the non-Skype software mix is much different than on your PC, and is there the possibility of re-locating the problem machine temporarily for further testing (hopefully it's a notebook)

btw, I'm using XP SP3 as well

I understand that the problem machine won't connect to the Skype network, but I also can't help wondering if there might be something else altogether that might be causing the issue
Regards,
Neil
Please use plain text.
Neil
Super Adventurer
Kudos: 273
Posts: 4827
Registered: 27-06-2011
Message 6 of 12 (4,458 Views)

Re: missing "Enable uPnP" checkbox

[ Edited ]

Hello,

I'm sorry I'm not very helpful, but:

 

- both PCs are wire-connected

- we tried the latest available versions (from 5.5 to 5.8 ), but still no checkbox

- these are standard company domain machines, so the software is almost the same: office 2007, IE, Firefox and Adobe 9... not much else

- the problem machine is actually a workstation, but we could move it if needed

 

Thanks and best regards

Please use plain text.
LordRNK
Casual Adventurer
Kudos: 0
Posts: 5
Registered: 15-02-2012
Message 7 of 12 (4,434 Views)

Re: missing "Enable uPnP" checkbox

It is possible that uPnP is somehow disabled in Policies settings.

 

Open Windows Registry database (Windows Start –> Run –> regedit). Expand the key:

 

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Skype\Phone

 

Do you see any settings applied for this key?

 

Do the same for this key

 

HKEY_CURRENT_USER\SOFTWARE\Policies\Skype\Phone

 

Please use plain text.
ruwim
Community Ambassador
Community Ambassador icon
Kudos: 6408
Posts: 45834
Registered: 27-06-2011
Message 8 of 12 (4,414 Views)

Re: missing "Enable uPnP" checkbox

Hi,

I don't have anything related to uPnP under

 

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Skype\Phone

 

(see attached image), while I cannot find at all

 

HKEY_CURRENT_USER\SOFTWARE\Policies\Skype\Phone

 

I only have

 

HKEY_CURRENT_USER\SOFTWARE\Skype\Phone

 

without \Policies, but even in here I cannot find anything uPnP-related.

 

Any other ideas?

 

 

Thanks and best regards

Please use plain text.
LordRNK
Casual Adventurer
Kudos: 0
Posts: 5
Registered: 15-02-2012
Message 9 of 12 (4,408 Views)

Re: missing "Enable uPnP" checkbox

If the Policies are set for all users on a particular machine, then the settings will be in HKEY_LOCAL_MACHINE. If they are applied only to the current user, then you will find them in HKEY_CURRENT_USER key. Apparently, the Policies applied by your company are for all users and they are quite extensive.

 

I’m not especially familiar with the different policy settings, but you can try to change the value of the sub-key “DisablePersonalise” form 1 to 0. Perhaps this will enable personalisation of the Skype client, incl. connection settings.

Please use plain text.
ruwim
Community Ambassador
Community Ambassador icon
Kudos: 6408
Posts: 45834
Registered: 27-06-2011
Message 10 of 12 (4,400 Views)
Reply

© 2014 Skype and/or Microsoft. The Skype name, associated trade marks and logos and the "S" logo are trade marks of Skype or related entities. Use of this website constitutes acceptance of the Terms of Use and Privacy and Cookie policy.

No emergency calls with Skype
Skype is not a replacement for your telephone and can't be used for emergency calling