Constantly losing connection

Welcome to the Skype community. To get started please read our short welcome post. Thanks!
Showing results for 
Search instead for 
Do you mean 
This topic has been archived.
To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Reply

Constantly losing connection

Apologies in advance if this is the wrong area for this- I've been a little lost and hoping I found the right place.

 

I've had Skype installed on this computer since about the 7th of July or so, and it had been working fine ever since, until recently, about a week or two ago. At first, I had people telling me I was constantly flittering on and offline. From my end, I never saw this, so I ignored it.

 

A few days ago, I started seeing my status symbol changing to the grey circling log-in icon. Strangely though, I was still connected- I could see my friends' status, and still send and receive IMs in chatrooms, no issue. Starting the other day, however, it's gotten worse- now I actively lose connection from Skype every 20 seconds or so I'm logged in, and it can take several minutes for any messages of mine to get through. Occasionally I still seem able to receive messages from others, but mine take forever to get through.

 

It's also only Skype that has this issue. I've watched my internet connection (dial-up), and haven't seen any unusual behaviour from it. Likewise, my web browser and other IM program work fine without issue. However, when I do login Skype, it causes massive lag to my internet and all internet programs- besides being slow, they constantly give me connection error-esque messages, until I log-off Skype, which seems to instantaneously fix the internet issue.  The internet lag may be from backlog from chat history, but I think it comes from constantly losing connection and trying to reconnect, even after I've caught up with missing chat history.

 

 I've tried several things to fix this- I've upgraded to Skype 5.5 (from 5.3), then downgraded to Skype 4.2, I've checked my Network Settings, I've partially or completely deleted my AppData for Skype, I've changed my password, I've disabled my Antivirus, double-checked the configuration of my Firewall... no help, the problem still persists.

 

At this point, I'm feeling pretty stumped with what it could be, and it's left me pretty much unable to use Skype at all now. I don't remember making any sort of changes to the computer that would suddenly (much less gradually but progressively) disrupt Skype's stability, but maybe something happened that I just overlooked, I don't know.

 

Any help on the issue would be appreciated. If there's any information needed to better understand the situation, please ask and I'll tell what I can. My current OS is Windows 7 Home Premium, Service Pack 1, and the Skype version I was originally using was Skype 5.3.0.120. Thanks in advance to any that can help me with this.

Araushnee
Casual Adventurer
Kudos: 0
Posts: 8
Registered: 29-08-2011
Message 1 of 22 (10,449 Views)

Re: Constantly losing connection

[ Edited ]

the Skype client for Windows is not designed to work over a dialup connection

Regards,
Neil
Neil
Super Adventurer
Kudos: 271
Posts: 4826
Registered: 27-06-2011
Message 2 of 22 (10,367 Views)

Re: Constantly losing connection

[ Edited ]

Hi Neil, thanks for the response.

 

Well, I've been using Skype for about two years with dial-up. From about May 2009 to June 2011 with Windows Vista 64-bit and Skype 4.x (I forget which version exactly) and then from July 2011 to now with Windows 7 64-bit and Skype 5.3. I've had no performance issues with Skype until this past Friday or so (08/26/11).

 

I also have at least two friends that have been using Skype on a dial-up connection, and I don't believe either have had issues with it before (and do not suffer the same issue I have now, apparently). While I don't know their OSs (though I could check if it would help), I'm pretty sure they both use some variant of Windows.

 

Unfortunately I don't think this is the source of my problem, else I probably should have never been able to use Skype with dial-up from the start. Unless there is a reason it wouldn't start giving me problems until the past few days.

 

For further info, I don't use Skype for calls or video/voice chats, or anything like that- just text messages. 

Araushnee
Casual Adventurer
Kudos: 0
Posts: 8
Registered: 29-08-2011
Message 3 of 22 (10,349 Views)

Re: Constantly losing connection

Please install over what you have with this, is it better or the same?

 

http://skype.com/go/getskype-em

 

 

TheUberOverLord
Aviator
Kudos: 500
Posts: 12505
Registered: 27-06-2011
Message 4 of 22 (10,345 Views)

Re: Constantly losing connection

Hi,

 

I tried installing that version over my current one, but unfortunately there was no change- the problem still persists.

Araushnee
Casual Adventurer
Kudos: 0
Posts: 8
Registered: 29-08-2011
Message 5 of 22 (10,323 Views)

Re: Constantly losing connection

[ Edited ]

Same issue here, my messages only delivers when person on other side writes me back. And I can not make a call to some of my contacts. Because their status drops to offline when I'm starting a call

John_Silver
Novel Adventurer
Kudos: 0
Posts: 2
Registered: 30-08-2011
Message 6 of 22 (10,311 Views)

Re: Constantly losing connection


John_Silver wrote:

Same issue here, my messages only delivers when person on other side writes me back. And I can not make a call to some of my contacts. Because their status drops to offline when I'm starting a call


 

Using the main Skype client program window please do:

 

Tools -> Options -> Advanced -> Connection

 

Please uncheck the enable uPnP checkbox and click the "Save" button.

 

Stop/Start Skype

 

Any better?


Note: If this works, you should disable this at the router/AP level.

 

TheUberOverLord
Aviator
Kudos: 500
Posts: 12505
Registered: 27-06-2011
Message 7 of 22 (10,290 Views)

Re: Constantly losing connection


Araushnee wrote:

Hi,

 

I tried installing that version over my current one, but unfortunately there was no change- the problem still persists.


Please go back to the normal version by installing over what you have from here: http://skype.com/go/getskype-full

 

Using the main Skype client program window please do:

 

Tools -> Options -> Advanced -> Connection

 

Please uncheck the enable uPnP checkbox and click the "Save" button.

 

Stop/Start Skype

 

Any better?


Note: If this works, you should disable this at the router/AP level.

 

TheUberOverLord
Aviator
Kudos: 500
Posts: 12505
Registered: 27-06-2011
Message 8 of 22 (10,289 Views)

Re: Constantly losing connection

[ Edited ]

Hi,

 

I tried as you suggested, unfortunately the issue still persists.

 

EDIT:

 

I've decided to try a test with a second account I made some time ago, and never really used. With this account, I'm able to log in and stay logged in with no problems. I added one of my friends to this account and we've been talking for a few minutes now, with no issues yet whatsoever.

 

Yet my main account continues to drop connection every half-minute or so.

 

What could cause my main account to no longer keep a connection to Skype and lag horribly, but allow a secondary account to still work fine? Some sort of issue with contacts? Chatrooms? I've already deleted all the AppData both for the troubled account, and the entire Skype folder, forcing Skype to re-create new ones, yet that didn't resolve the issue... could the account in question somehow be creating a corrupted file or something?

Araushnee
Casual Adventurer
Kudos: 0
Posts: 8
Registered: 29-08-2011
Message 9 of 22 (10,276 Views)

Re: Constantly losing connection


Araushnee wrote:

Hi,

 

I tried as you suggested, unfortunately the issue still persists.

 

EDIT:

 

I've decided to try a test with a second account I made some time ago, and never really used. With this account, I'm able to log in and stay logged in with no problems. I added one of my friends to this account and we've been talking for a few minutes now, with no issues yet whatsoever.

 

Yet my main account continues to drop connection every half-minute or so.

 

What could cause my main account to no longer keep a connection to Skype and lag horribly, but allow a secondary account to still work fine? Some sort of issue with contacts? Chatrooms? I've already deleted all the AppData both for the troubled account, and the entire Skype folder, forcing Skype to re-create new ones, yet that didn't resolve the issue... could the account in question somehow be creating a corrupted file or something?


This may sound insane, but could you be logged in somewhere else on that account? Change your password and that will force a logoff, if that is/was the case.

TheUberOverLord
Aviator
Kudos: 500
Posts: 12505
Registered: 27-06-2011
Message 10 of 22 (10,252 Views)
Reply

© 2014 Skype and/or Microsoft. The Skype name, associated trade marks and logos and the "S" logo are trade marks of Skype or related entities. Use of this website constitutes acceptance of the Terms of Use and Privacy and Cookie policy.

No emergency calls with Skype
Skype is not a replacement for your telephone and can't be used for emergency calling