Wake for incoming call

Welcome to the Skype community. To get started please read our short welcome post. Thanks!
Showing results for 
Search instead for 
Do you mean 
Reply

Wake for incoming call

I have an iMac 24" 2008. Is there a way to have it wake when a Skype call comes in. I know I can set the computer to never sleep but that wastes power and shortens its life. What happens is that after 15 min. the screen goes to sleep then after 1 hour the rest of the computer dozes off. I would like to have it wake and ring when a call comes in.

kkesp2009
Novel Tourist
Kudos: 0
Posts: 1
Registered: 22-12-2011
Message 1 of 3 (8,385 Views)

Re: Wake for incoming call

I have the same issue on my MacBook Pro 15" - by default, Mac OS X will dim the display, then after awhile turn off the display, finally after that it goes into a pseudo-sleep mode.. The Skype service doesn't always recognize the device is away/offline so my contact status is not properly updated..

 

There's 2 workarounds for this.

 

Solution #1 you need to be running at least 10.6 Snow Leopard and use an Airport Extreme base station or TimeCapsule as your router. It sends packets over Bonjour that keep the connection alive in sleep mode and will wake the machine when there's traffic over Ethernet (Wake on LAN) or WiFi (Wake on Wireless) to your Mac.

 

Wake on LAN is configured at the Power settings. Go to the Apple Menu -> System Preferences then click on "Energy Saver" -- click the checkbox next to "Wake for Ethernet network access" to enable it.

 

Wake on Wireless requires a later model Mac from about 2009+ I believe, to check and see if you have this feature, go to the Apple Menu -> About this Mac, click on "More Info..." then click on "System Report" on the next window that opens up. Now you are in System Profiler (System Information). Click on the Network section and look at the "Airport" data sheet for a line that says "Wake on Wireless" -- if it's there then you have that ability too. If not, then you need to be hardwired and use Wake on LAN instead.

 

Solution #2 is a workaround and what I do (since my MacBook Pro is older). Under the "Energy Saver" System Prefs I set both Computer Sleep and Display Sleep to Never, and under "Security and Privacy" make sure the "Require password __ after sleep or screen saver begins" is unchecked, and finally under "Desktop and Screen Saver" I set the "Start Screen Saver" to Never. This absolutely prevents the machine from going to sleep. Next I manually turn the volume up and dim the display brightness using the keyboard controls. Once the display is set all the way down, it actually shuts off the screen even though the computer is still running.

 

You can then hear it if someone calls you or skype messages you. I close down any other apps that would make noise, including Mail (you can always create rules to chime in if you want to be alerted of certain incoming mail or what not), and of course you manually turn the brightness back up to see what's going on (or not, if you don't want to, LOL, you just made your Mac become a glorified speakerphone).

 

That may not be the best solution of course but until something better comes (or I get a newer Mac) that works for me.

ccalhoun
Routine Adventurer
Kudos: 28
Posts: 15
Registered: 13-08-2011
Message 2 of 3 (8,264 Views)

Re: Wake for incoming call

Thank you so much. I want to read more of this kind, but even if I use only your recommendations, I'll be far ahead of the game. I suppose that one also could choose "Sleep" from the Apple menu and put the computer to sleep manually when no Skype call was expected.

 

Thanks again,

 

jenny

 

jennywren1420
Routine Adventurer
Kudos: 1
Posts: 23
Registered: 19-03-2013
Message 3 of 3 (2,140 Views)
Reply

© 2014 Skype and/or Microsoft. The Skype name, associated trade marks and logos and the "S" logo are trade marks of Skype or related entities. Use of this website constitutes acceptance of the Terms of Use and Privacy and Cookie policy.

No emergency calls with Skype
Skype is not a replacement for your telephone and can't be used for emergency calling