Skype doesn't ring with incoming calls

Welcome to the Skype community. To get started please read our short welcome post. Thanks!
Showing results for 
Search instead for 
Do you mean 
Reply
Accepted Solution

Skype doesn't ring with incoming calls

[ Edited ]

Hi there, I'm on Skype 5.7.59.1037 which should be the latest mac release.
My MBP is running Lion which is completely updated as well.
I checked the notifications settings and everything looks properly set up, but for some unknown reason, when someone calls me I get no ringtone, all the other sounds work perfectly...
I also tried uninstalling skype using CleanMyMac (I believe it removed any file related to skype) and install it back from scratch, no change whatsoever...
Is someone experiencing the same? and more over any idea what could be the issue here? 
Thanks! 

Nick.K9
Staff Moderator

images.message_type_solution.altAccepted Solution

0 Kudos

Is your status set to Do Not Disturb?

View solution in original post
Matita
Novel Adventurer
Kudos: 5
Posts: 2
Registered: 06-02-2012
Message 1 of 59 (51,977 Views)
Nick.K9
Staff Moderator
Staff Moderator icon
Kudos: 73
Posts: 473
Registered: 23-09-2013
Message 42 of 59 (24,618 Views)

Re: Skype doesn't ring with incoming calls

am sure you have already tried this but if you have not then try the following.

 

go to preferences, then go to notification, and select sound releted to calls. also go to audio / video settings and select built in output in speakers and make the volume to max.

 

hope this helps.

Vihang
Casual Adventurer
Kudos: 6
Posts: 8
Registered: 14-04-2012
Message 2 of 59 (51,970 Views)

Re: Skype doesn't ring with incoming calls

I am having the same problem as Matita. All software is updated. When someone tries to call me, I do not get a ring. I get the notifications later, no set time. This has happened while I am using my computer, so I know it's not a sleep mode issue. The caller tells me when they call, it goes straight to voicemail. Any ideas?

michaelwelch848
Casual Tourist
Kudos: 3
Posts: 1
Registered: 03-04-2012
Message 3 of 59 (51,952 Views)

Re: Skype doesn't ring with incoming calls

Same problem and have tried the suggestions offered.  I am on iMac and the latest version.

 

When clicking on Skype>Preferences>Notifications the "Play Sound" box is ticked but is greyed out and not useable.

Remarkables
Novel Tourist
Kudos: 2
Posts: 1
Registered: 17-04-2012
Message 4 of 59 (51,939 Views)

Re: Skype doesn't ring with incoming calls

[ Edited ]

Hi,

 

Did you check Mac System preferences >>> Hardware >>> Sounds >>> Sounds alerts also ?

* * * * * *
On ne regarde pas l'avenir dans un rétroviseur ! :wink:
IMac Intel Core i3 3.2 GHz - RAM 12 GB - OS 10.9.5
Skype 6.19.0.452
Logitech usb headset or Jabra 250 bt
Foyan
Community Ambassador
Community Ambassador icon
Kudos: 1138
Posts: 8939
Registered: 27-06-2011
Message 5 of 59 (51,937 Views)

Re: Skype doesn't ring with incoming calls

Yes I have the same problem with sound effects after my recent upgrade. The 'play sound' section in my preferences is greyed out, and none of the above suggestions, or taking away configuration files has helped. Please Skype, fix this!
tiesje
Novel Tourist
Kudos: 2
Posts: 1
Registered: 25-04-2012
Message 6 of 59 (51,848 Views)

Re: Skype doesn't ring with incoming calls

This has been driving me crazy for a few months now (since upgrading from 2.8.x) and today I finally took the time to track it down. Like everyone else here:

 

  • Incoming calls produced no sound
  • In my "Notifications" preferences, the "Play sound" checkbox was unchecked and disabled (greyed out)

 

Here's what I did to fix the problem:

 

  • Open ~/Library/Preferences/com.skype.skype.plist in your favorite plist editor. For me, it opened in XCode by default, but it also opens fine in a text editor like TextWrangler. The plist file is just an XML text file at its core.
  • Find the option named "MuteAllAlertSounds".
  • Change the value from true/yes to false/no. If you're opening it in XCode, you'll change the "YES" value to "NO". If in a text editor, you'll change this...
	<key>MuteAllAlertSounds</key>
	<true/>

    to...

	<key>MuteAllAlertSounds</key>
	<false/>
  • Save your changes
  • Restart Skype

Now my "phone" actually rings and the "Play sound" checkbox is no longer disabled.

 

I hope that helps someone else.

robwilkerson
Casual Adventurer
Kudos: 4
Posts: 11
Registered: 28-11-2011
Message 7 of 59 (51,833 Views)

Re: Skype doesn't ring with incoming calls

Thank you so much, it worked perfectly.
leonardoDP
Novel Tourist
Kudos: 0
Posts: 1
Registered: 27-04-2012
Message 8 of 59 (51,800 Views)

Re: Skype doesn't ring with incoming calls

Hey, i can't fint the file /Library/Preferences/com.skype.skype.plist. Skype is 5.7.0.1130, And is in Lion OSX 10.7.4

Thanks!
sebasoy
Novel Tourist
Kudos: 0
Posts: 1
Registered: 24-05-2012
Message 9 of 59 (51,591 Views)
Reply

© 2014 Skype and/or Microsoft. The Skype name, associated trade marks and logos and the "S" logo are trade marks of Skype or related entities. Use of this website constitutes acceptance of the Terms of Use and Privacy and Cookie policy.

No emergency calls with Skype
Skype is not a replacement for your telephone and can't be used for emergency calling