Skype 5.3 for Mac OS X requires Mac OS 10.5.8 or l...

Welcome to the Skype community. To get started please read our short welcome post. Thanks!
Reply

Skype 5.3 for Mac OS X requires Mac OS 10.5.8 or later ??

How come that You write Skype 5.3 for Mac OS X requires Mac OS 10.5.8 or later

when I download this file it's named Skype_5.3.59.1093.dmg

 

And Skype 5.3 for Mac OS X it doesn't work on my iMac power pc with 10.5.8

 

Wich is correct . Can it be used by my computer or not.

 

When I start Skype it says it cant be running this computer,

 

Yours Sincerely

 

Imelda Chavez / Anders Wikberg

info@acm-photo.se

 

anders.wikberg@telia.com

 

imelda.chavez@telia.com

acm_photo_se
Casual Tourist
Kudos: 0
Posts: 1
Registered: 14-11-2011
Message 1 of 2 (1,392 Views)

Re: Skype 5.3 for Mac OS X requires Mac OS 10.5.8 or later ??

The latest versions of Skype will NOT run on a PowerPC.  They require an Intel processor, no matter the version of the Mac operating system you are using.  That said, you can download older versions from oldapps.com/skype.php.

--
Entia non sunt multiplicanda praeter necessitatem.
mkichaa
Community Ambassador
Community Ambassador icon
Kudos: 255
Posts: 1517
Registered: 27-06-2011
Message 2 of 2 (1,285 Views)
Reply

© 2014 Skype and/or Microsoft. The Skype name, associated trade marks and logos and the "S" logo are trade marks of Skype or related entities. Use of this website constitutes acceptance of the Terms of Use and Privacy and Cookie policy.

No emergency calls with Skype
Skype is not a replacement for your telephone and can't be used for emergency calling