Re: Non-intel Macs??

Welcome to the Skype community. To get started please read our short welcome post. Thanks!
Showing results for 
Search instead for 
Do you mean 
This topic has been archived.
To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Reply

Non-intel Macs??

DSL has finally become available in my rural community!  I fired up skype 2.8 on my G5 Mac and it suggested there was an update.  Did the update only to find that it does not support my architecture.

 

Has Skype dropped support for the older non-intel macs running OSX 10.5.8?

0 Kudos
MichaelWV
Novel Tourist
Kudos: 0
Posts: 1
Registered: 15-04-2012
Message 1 of 3 (727 Views)

Re: Non-intel Macs??

The latest iterations of Skype (v5.x) require an Intel processor.  All is not lost, however.  Download v2.8 (or older versions) from oldapps.com/skype.php.  That should do it.  When you've installed it, disable the 'check for updates' option to avoid the problem in the future.

--
Entia non sunt multiplicanda praeter necessitatem.
0 Kudos
mkichaa
Community Ambassador
Community Ambassador icon
Kudos: 342
Posts: 1599
Registered: 27-06-2011
Message 2 of 3 (724 Views)

Re: Non-intel Macs??

About a month ago my non Intel, PPC Mac stopped being able to video cam with Skype 2.8. Seems Sype does not want to answer this question.

0 Kudos
SolidArtyMan
Casual Adventurer
Kudos: 1
Posts: 5
Registered: 28-04-2013
Message 3 of 3 (232 Views)
Reply

© 2014 Skype and/or Microsoft. The Skype name, associated trade marks and logos and the "S" logo are trade marks of Skype or related entities. Use of this website constitutes acceptance of the Terms of Use and Privacy and Cookie policy.

No emergency calls with Skype
Skype is not a replacement for your telephone and can't be used for emergency calling