Re: Ubuntu 14.04 / Skype 4.3.0.37 audio input not ...

Welcome to the Skype community. To get started please read our short welcome post. Thanks!
Showing results for 
Search instead for 
Do you mean 
Reply

Ubuntu 14.04 / Skype 4.3.0.37 audio input not working

I can't get audio input to work on Ubuntu 14.04 with Skype 4.3.0.37. All settings are ok, I have verified with pavucontrol, mic is working fine in all other applications. Any ideas?

ziggurat
Novel Tourist
Kudos: 2
Posts: 1
Registered: 10-07-2014
Message 1 of 6 (2,116 Views)

Re: Ubuntu 14.04 / Skype 4.3.0.37 audio input not working

the following thing worked for me:

 

sudo apt-get install pavucontrol

 

that will  also install pulseaudio server which will provide the virtual device for skype. If that still does not work, go to skype "sound devices" settings and launch "Open pulseaudio volume control". There ou can check which input/ouput devices are on/off and set the right thing for you.

zx12
Novel Adventurer
Kudos: 2
Posts: 3
Registered: 07-08-2014
Message 2 of 6 (1,756 Views)

Re: Ubuntu 14.04 / Skype 4.3.0.37 audio input not working

I'm having the same problem. When I select Options/Sound Devices in Skype, there is only one option in the dropdown menus for Microphone and Speakers: "Virtual Device." See the screenshot:

skype.png

I have PulseAudio Volume Control-- it seems that skype isn't recognizing that.  Audio, mics, speakers work fine on all other applications.

pure_toast
Novel Adventurer
Kudos: 0
Posts: 2
Registered: 14-08-2014
Message 3 of 6 (1,541 Views)

Re: Ubuntu 14.04 / Skype 4.3.0.37 audio input not working

I had the "virtual device" thing before I installed pulseaudio. Now it says "pulseaudio server (local)". Could it be that pulseaudio server is not installed (that would be strange however, since you have pavucontrol) ? Try to reinstall pulseaudio:

 

sudo apt-get install --reinstall pulseaudio pavicontrol

 

The fact that sound/mic is working in all other apps does not mean that pulseaudio is installed, because all other apps use another sound server. Pulseaudio is a requirement by microsoft, and it is only required by skype as far as I know.

zx12
Novel Adventurer
Kudos: 2
Posts: 3
Registered: 07-08-2014
Message 4 of 6 (1,479 Views)

Re: Ubuntu 14.04 / Skype 4.3.0.37 audio input not working

I tried that... Skype still gives me the same options.  And now, when I open pavucontrol, I see this:

PAvuC.png

 

What to do?

pure_toast
Novel Adventurer
Kudos: 0
Posts: 2
Registered: 14-08-2014
Message 5 of 6 (1,454 Views)

Re: Ubuntu 14.04 / Skype 4.3.0.37 audio input not working

Hi, I am sorry to propose you again the same thing, but it really seems like you pulseaudio server is not configured correctly. So, I suggest removing the pulseaudio server together with its configuration like so

 

sudo apt-get remove --purge pulseaudio

 

Then check that config files in  /etc/pulseaudio/* do not exist, if they do, remove them.

Then remove local config directories: probably ".config/pulse" and maybe also ".pulse" from your home directory.

 

then run again

 

sudo apt-get install pulseaudio

 

That is all I can suggest. Configuring pulseaudio manually is not my cup of tea.

 

(You might also try to remove skype with  its configuration files,

  sudo apt-get remove --purge skype

  rm -r .config/Skype

  rm -r .Skype

and then reinstall skype. Beware that removing Skype config will also remove your skype log files)

zx12
Novel Adventurer
Kudos: 2
Posts: 3
Registered: 07-08-2014
Message 6 of 6 (1,365 Views)
Reply

© 2014 Skype and/or Microsoft. The Skype name, associated trade marks and logos and the "S" logo are trade marks of Skype or related entities. Use of this website constitutes acceptance of the Terms of Use and Privacy and Cookie policy.

No emergency calls with Skype
Skype is not a replacement for your telephone and can't be used for emergency calling